"Failed to Connect to Swarm"


I am having an issue with “failed to connect to swarm” I have tried everything I can find on the web inc. legacy wiki to fix it. I have tried uninstalling my firewall, I tried forwarding the ports in the firewall for the swarm agent and coordinator. I tried removing all traces of Unreal from my computer and registry and reinstalling, I tried verifying install. I tried a build from source code, I am still getting the error? Anyone have any other ideas? I get the following in the logs:

Starting up SwarmAgent ...
 ... registering SwarmAgent with remoting service
 ... registering SwarmAgent network channels
 ... initializing SwarmAgent
 ...... checking certificate
 ......... certificate check has failed
 ...... initializing cache
 ......... using cache folder 'C:\Program Files\Epic Games\UE_4.24\Engine\Binaries\DotNET/SwarmCache'
 ......... recreating SwarmAgent cache staging area
 ...... initializing connection to SwarmCoordinator
 ......... using SwarmCoordinator on RENDER-01
[PingCoordinator] Determined that we couldn't ping the coordinator
[PingCoordinator] Coordinator ping failed
 ......... SwarmCoordinator failed to be initialized
 ...... initializing local performance monitoring subsystem
 ...... local performance monitoring subsystem initialization failed

In case anyone ever comes across this themselves, it was a Windows 10 configuration issue, preventing the performance monitor from initializing. Going into C:\Users\AppData\Local\UnrealEngine\Saved\Swarm going into the SwarmAgent.DeveloperOptions.xml and changing true to false will get you running again while you figure out what Windows is doing.

For anyone else running into issues.
Specifically: … SwarmCoordinator failed to be initialized
If you are like me and having problems with running UE4 swarm agent on the same machine you’re running the swarm coordinator, try setting the agent “CoordinatorRemotingHost” to localhost.


1 Like

The only way I can think to up-vote this response.

The symptoms of my problem were similar enough that it lead me here. Essentially, any lighting build, whether it was on a fresh “basic” level map or a more complex environment, would hang the editor for nearly 3 minutes before anything would happen. After looking at the swarm log I noted output similar to that of the original post. Ultimately it couldn’t ping the coordinator and was waiting 90 seconds in two separate spots at startup simply attempting to communicate with the SwarmCoordinator which defaults to RENDER-01 !!! What’s bizarre to me is that I never noticed this before which makes me feel like this behavior is new…not the RENDER-01 thing but the 90 second timeouts.

Either way, following @BRG_Kara 's advice, I set the hostname of the coordinator to localhost and viola, the agent could communicate with the coordinator and no more 90 second pauses to sit through…thanks!!

Where did you change that?

If you haven’t found it already, you need to open up the swarm agent by double-clicking in the app panel


Once that is up there is a settings tab. You’ll find the options there.

1 Like

This helped tremendously, thanks!

I moved my engine to a new drive and wasn’t sure why swarm was not working. That did the trick.

To be clear for others, you’ll see swarm in the lower corner of your windows, you might have to hit the little hidden items tab on windows 11.

Putting in the correct location let the engine find swarm agent.