Excluding Objects from a Light


Is it possible to exclude certain objects from a light? I have a scene that uses fill lights and the fill lights have their shadows off. Im getting really great results with this method with minimum performance lost, but the objects on the second floor are being uplight by my first floor fill lights. How can I excluded the second floor actors from my first floor fill lights?

Can anyone provide any type of feedback to a solution for this?

You can use the newly introduced light channels in 4.11 for this I believe.

Sweet, thanks Jonimake. I’m still using 4.10. I’ll look into this light channels option. Thanks again!

You used to be able to do this in UE3 with lighting channels. They removed this in UE4.
However, it was recently added back in UE4 4.11 so you’re in luck. There’s no way to do this in UE4 4.10 sorry

Thanks Jak, just upgraded to 4.11. I’ll give it a shot!