Everything is disappearing when world origin is not in a viewport

I have setup this scene while following this tutorial% Unreal Engine 5 - Create Planets - YouTube

When I look in a direction where the world origin (0,0,0) is not in the viewport → everything is becoming black. If I add a sky atmosphere to the scene → there would be a strange render flip whether world origin IS in the scene or not

Is it a bug or am I missing something? Thanks in advance!

1 Like

Click on the meshes, and increase


Thanks for advice. Just tried this out but unfortunately no effect :roll_eyes:. Screen still goes black even with some ridiculous numbers

Are these meshes very large?

I assume so! Following the tutorial spheres where made with 1.000.000 radius and then Earth sphere is scaled by 10, stars sphere is scaled by 1000

You might get around the problem by ticking ‘render custom depth pass’

Have played around this setting - this didn’t worked out either.

I think you might be in for a ‘world of pain’ if you’re trying to make a real scale universe… :slight_smile:

Could you please advice any workaround?

What I am trying to setup is a scene where a player pawn is heading in the direction of the Earth. I have setup a flying platform in another level and would like to place it in this “space” scene. Making Earth and stars sphere small would probably kill the scale effect of player slowly heading the Earth

There are quite a few space to earth transition vids

1 Like

Could this be a similar issue to this?

It seems very similar, thanks! But I eventually ended up making a hack to simulate desired visual behaviour on a very low scale :smiley: