Download

@EPIC: Please don't minimize editor during VR preview

Hi there,

Like most (?) UE4-devs I’ve got a dual monitor setup. Every time I start a VR preview, all UE4 editor windows of all displays get minimized for no appearent reason. I have to restore my blueprint editor window every time by hand for being able to debug etc.

Why isn’t the VR preview window not simply rendered on top off the other windows, similar to Play → ‘New editor window’?

Thanks,
spyro

I think they are doing this because when the editor is minimized it uses a lot less CPU/GPU resources, and we all know that we need as many resources as possible for VR rendering.

Personally i use a single monitor and i find it usefull, but yeah maybe Epic could add a config option somewhere to enable/disable this behaviour.

Actually, to drastically reduce CPU/GPU-consumption, it’s enough if the editor isn’t in the foreground. I am restoring it everytime by hand now (having to alt tab, then restore, then move, then klick into the window again). There is no performance difference.

It’s just very annoying to do this every time just to view the active blueprint window and are being able to use the debugger. This wouldn’t be the case, if the window would just open on top instead of minimizing the editor.

I’d have to test the performance. I’m certain they did it to eliminate any possible performance interference though. I don’t have any issue with minimizing it, since I would always do that anyway. I see you’ve tested it though, so perhaps you’re right. As long as there’s not an issue with leaving it up, it doesn’t matter to me.

Sup dude, if you don’t want to minimize the editor when VR happens then take a look at line 2838 in PlayLevel.cpp. You should take a closer look at the source code if you’re going to be playing with this thing so much.



// minimize the root window to provide max performance for the preview.
TSharedPtr<SWindow> RootWindow = FGlobalTabmanager::Get()->GetRootWindow();
if (RootWindow.IsValid())
{
	RootWindow->Minimize(); // just comment this out, maybe...
}

Cheers.

Great find, doesnt hurt to have an option to adjust this for multi monitor setups.

Yes, a simple option would be the best solution, especially for everyone who uses the binary versions provided by Epic. But thanks to Ogreveins, anyway. That’s a good workaround for people who are compiling their own version of the engine.

Why is this not a thing yet? Hello?! Such a waste of time because of this.

Minimising the editor should be an option, as I’d love to disable it as well. Especially seeing as the print command doesnt seem to print to VR preview.

Part of me finds this topic amusing because during VR preview, in theory, the headset is on your face, and you can’t see the editor anyway… so why does this matter?

But I get it, you want to see debug info when testing stuff. When this started to annoy me (because I wanted to see debug info or whatever), I simply started printing that info to the log.

And then, you know, looked at the output window when I was done.

If I needed something more visual, I just started drawing debug lines around stuff, and then just infer success based on that. “Oh there’s the debug line, that function worked”.

It’s not a pretty solution, and of course I’ve gotta go back in and remove that stuff before packaging, but then I also don’t need the editor open and can focus on just wearing the headset. I do agree it should probably be an option though, especially if it’s as easy as simply commenting out that line as @Ogreveins posted.

Thread bump. I cant just use debug lines while trying to get my AI behaviour tree working. And the project is VR-only so using preview doesnt allow me to test anything.

This not exactly what your looking for, but if u go under the Level Editor-> play menu in editor prefs, you can turn on “Viewport Gets HMDControl”, u can move the hmd around and use motion controls and keep any editor windows running. You wont get hmd output video, but at least u can debug easier.

Unreal really just needs to have the normal editor not minimize in vr playback as an option.

Checking that box doesnt seem to have any effect. Playing in editor doesnt allow me to look with the hmd, or see my controllers. :frowning:

+1 Not keen to be recompiling the whole engine to change something so trivial, and easy debugging should be a given even in VR mode.

+1 trying to debug our VR experience it is very annoying to have to alt+tab to get the editor back.

is there any solution for that?

Turned out it was a bug in VR preview not rendering correct resolution. Once fixed we had to optimize our rendering a bit.

+1 This really needs to be an option to switch on and off.

+1. Need the Blueprint to be up 30% of the time, e.g. run game, do stuff, set breakpoint in code.

Glad to see others have suffered over this issue as well and that there isn’t am easy fix, now I can move on with life :wink: