[Epic Official] FBX Import Reporting

Well, we import FBX in from Maya2014 and the character always facedown when we play their animation.

I had a topic here in your forum: Character always face down (FBX Import) - Content Creation - Unreal Engine Forumslink text

Attached below is an example of the exported file. Hope this help, Go Unreal Team!

Hello, I have a some bugs with maya rig tool aswell…

0th. - Wrong path by loading mannequin d/:build/unreal4~ and when I use browse and use the real path, it does not save though I check it to save… and the next time I try to open mannequin it gives wrong path again…

another problem is with exporting fbx file with some character created with rig… when I use export selected from file list it gives me 2 warnings

1st - complex animation baked. 47 attributes had complex animation. Complex animation was exported as baked curves. (4747 evaluations done)

2nd. - The fbx plug-in does not support assets created by advanced asset menu. The following container(s) will be ignored: irvelnaujas:JointMover. (at the end I get a fbx file that can’t be used… even after importing back I get only some foot wireframes or so…) and it does not load in ue4…

3rd. - Error: ValueError: file C:/Program Files/Unreal Engine/4.0/Engine/Extras/Maya_AnimationRiggingTools/MayaTools/General/Scripts\ART_poseEditor.py line 944: could not convert string to float # when I try to use hand poses.

At the end rigging tool becomes pretty useless… ;(

Would be glad to know if these errors could be fixed. Thx in advance. (wrote on other thread too but dunno which is main so sry is repeating)

I have issues with custom collision meshes when they have curved surfaces.

I have a mesh that encompasses the four sides of a house with a door and 6 windows with rounded top parts. The mesh is quite simple, except for the rounded window tops. I then copy this mesh and rename it to act as a custom collision mesh.

After import into UE, I get the correct mesh, but a distorted collision mesh. it seems as if some vertices of the collision mesh move up Z for some reason. Also, the bounding box is three times a high as the one of the actual mesh.

FBX model exported using Modo 701

I modelled this inside of a freight elevator yesterday (there are other pieces like truss supports and two gates attached at the exit door that work fine).
The import process takes forever (it’s not like UE4 freezes or something, it’s completely functional according to the task manager).

When I import it, the progress bar just moves there endlessly. It seems that the polycount is causing this problem, because when I delete some parts, the mesh imports normally. That is why the truss supports and the two gates I modelled separately in the original modo scene file imported nicely, as they had really only a few polygons.

My tests gave me the following results:

0-1000 polys import works fine

~1000 or more start causing this problem

Hey Atle, just an update, I managed to repro this with your asset and it has now been fixed internally. Once it is tested and ready to go, it will be pushed out to the public.

Hello,

Could you please post the Maya rigging issues you are experiencing in a new question? They are being looked into by a different developer and it is easier to track if it is in a new post.

Thanks!

If you exported the animations in the Z-Up format, did you also go back and reexport/import the character’s Skeletal Mesh with Z-up?

Can you provide either an FBX of the asset with the collision or screenshots of it before and after importing? Any additional information will help in my investigation.

Hi Alexander

First of all, please fix this site (I tried to post this for the 6th time now):

No attachments over 512 KB (!)

  • I am referencing my post on custom collision meshes with curved surfaces. Directly replying to your commend did not work (clicking submit does not do anything)
  • Direct attachments are limited to 2 (a tad higher would be helpful so others can see attachments without downloading the whole zip)
  • Formatting gets messed up if bullet points are used

I love to help out, just don’t make me jump through hoops for it.

Attachment ZIP

I have attached a zip with 4 files in it:

Image 1 shows the mesh in Maya

  • Middle: Original mesh
  • Left: Copy for collision (does not work)
  • Right: Simplified version for collision (works ok)

Image 2: The result after import in UE (skewed collision mesh)

Image 3: In UE with bounds turned on as well (didn’t make it into the zip as for the 512 KB limit)

FBX: The geometry as exported from Maya.

Hope this helps,
cheers, Micheal

Hello,

I have a problem importing the collision mesh of an asset.

It used to work in UDK, but now, the editor generates a computed collision geometry instead of the one in the FBX.

Clicking in the editor in Collision > Copy Collision from Selected Static Mesh show a popup with the message :

Invalid asset to copy collision from. Select valid StaticMesh in content browser.

https://d26ilriwvtzlb.cloudfront.net/5/55/Baskethoop.zip

Thanks in advance

This mesh crashes unrealengine editor pretty stable.

You should check ‘combine mesh’ option to reproduce

https://dl.dropboxusercontent.com/u/19986711/unrealengine/bugs/cs_italyout4.fbx

Can you provide an example please? Being able to see the issue will allow us to work on a solution.

Hello,

Thank you for this asset. I did crash immediately when importing and have since entered a report to our importing developer. Please let us know if you have any more assets that are causing a crash.

Thank you!

Quick update, this is now fixed internally. Once the fix is ready to be put out, we will patch it in. Thank you!

Hi,

A couple of our asset’s cause a crash, it appears quite random as 95% of them work fine. Below is a link to one of the assets and a screenshot of the import settings.

I notice that I get BIND_POSES invalid warnings on any biped skinned meshes I import from 3dsmax 2013 x64. I’ve tried updating to the latest FBX plugins. I’ve also tried all the settings (and many variations of them) as suggested by the docs. I’ve tried several scale factors, resetting xforms, checking bone scales are 100% and remaking new bipeds.

This also happens on importing newly created bipeds with a simple sphere (edit poly or edit mesh) skinned to an entire bone (as a test).

Can you provide a test asset for me? I can then use it with our fix and see if it resolves the issue. Then you can know that it will be fixed in an update.

Thanks! Great news :slight_smile:
The UE4 pipeline is very fast/simple already, but this makes it stellar.

So ive used the Autorigging tool from Daz 3D . and i know that the bones/skeleton is the issue, with C4D works whitout Problems.

here is the File : File-Upload.net - Datei nicht gefunden

Everytime get a Error when i Import it in unreal engine 4 for a Skeletal Mesh

have a answerhub thread for this : Why won't my FBX SkeletalMesh import? - Character & Animation - Unreal Engine Forums

Edit :

We have solved the problem now, I just had to reassign the mesh to the rigg