[Epic Official] FBX Import Reporting

FBX is incorrect on import.

link text

Grab this dxf: http://www.us.kohler.com/webassets/kpna/cad/3812.dxf

Use the free FBX converter tool from Autodesk: Autodesk | 3D Design, Engineering & Construction Software

The resultant FBX imports but is missing sections.

The FBX viewed within the above mentioned FBX converter displays the FBX properly.

Any news about that issue?

Hello,

Thank you for your patience. I was able to reproduce the issue and have since entered a report to our importing developer. He will assess and rectify the error.

Thanks!

Thank you for that asset. I was able to test it in the 4.0.2 and can see that it causes a crash. I checked into it and the crash has since been fixed internally. Once it is ready, it will be put out to the public in an update. Thank you for your patience.

Cheers!

Hello,

Sorry for the wait, thank you for your patience. I was able to test this issue and reproduce it. I have entered a report about collision models not being brought over correctly based off of this and other user reports.

Thanks!

cool, thanks!

Hello,

Could you please give me a test asset that is experiencing this issue? It sounds like you are having the same problem with bind poses that has been reported before, so I would like to check it to make sure that we are fixing it.

Cheers!

I should mention that there was a Warning when I did the import:
Warning: No smoothing group information was found in this FBX scene. Please make sure to enable the ‘Export Smoothing Groups’ option in the FBX Exporter plug-in before exporting the file. Even for tools that don’t support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing.

Here’s what the FBX looks like according to the Autodesk Viewer (built into the above mentioned converter).

Here’s what the FBX looks like when I import it into UE4:

Thanks for the suggestion. Invert normals was one of the first thing I tried. I’ve tried many combinations of the advanced settings at this point. :frowning: But I don’t see a two sided option.

You need to reverse the normals on your mesh before import or set the material to two sided

any chance i can have a look at the fbx?

Sure. It’s zipped up in the original post but here it is again:
4510-3812.zip (223 KB)

Was like I thought; took the mesh into Maya reversed the Face Normals then re-exported it and now it works fine. Though you might want to look at setting up the UVs for it.

[Mesh with fixed normals][2]

Hello,

Thank you for your report. We are aware of an issue with the Blender animations being exported to UE4 and our developers are working on a solution.

Cheers!

Woohoo! Thanks Mr. Emperor! I’m looking forward to trying this when I get home tonight. I don’t have Maya but maybe Blender can do the same thing?

Odd that ticking the “Invert Normals” checkbox on import into UE4 didn’t seem to have any affect.

Status update for the insanely curious…

Blender doesn’t seem to help here. I’m not seeing a Reverse Normals options on export. I’m completely new to Blender so there’s probably an option somewhere to do this but I’m not seeing it.

At this point importing Immortal Emperor’s version of the FBX works fine until I build the level. At that point the toilet turns pitch black. I can work around this issue by making the toilet movable.

Hello, sorry for the wait. I just wanted to let you know that the BIND POSES error is a known issue that is being worked on.

When I try to import the Skeleton into the engine with Import Rigid Mesh option on it starts to import but within a few seconds it crashes. If I do not check that option only the part of my mesh that imports is the deform part. This has been an issue in 4.0.2 and 4.1.0 and it only happens if I export it from blender, but it has no issues importing into other programs and viewers and the problem only happens with this skeleton.

Edit: Wrong Mesh
The fbx is here: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

Hey Evenios -
Thank you for your report. Can you please upload an asset that caused this crash so we can investigate further?