[Epic Official] FBX Import Reporting

Hello UE4 Community!

We would like to focus some testing and development effort on our FBX importer, to help improve its usability and fix bugs. One thing that would really help us would be to share any problematic assets (source plus fbx) the community has on hand so we can test using them. If you have had trouble with our FBX importer and are willing to share your original assets (or simpler test assets demonstrating the same problems), here is what we would like you to do:

  • Add a comment including:
    • A description of what the problem is (i.e. crash, asset looks wrong on import, etc)
    • Attach source (.max,.mb, .blender etc) and fbx assets having the problem (in a .zip)
      • If the assets max out our attachment file size limit, you can upload a .zip to the Unreal Engine Wiki and include a link to the page.

We know the asset sharing solution here is a bit clunky, and are working on getting a better solution in place. For the time being, please send us your assets through this method as we wanted to get ahold of whatever we could to get a better idea on specifics of how and where the importer needs most improvement.

Thank you for your help!

-Alexander

I tried attaching a .fbx file (in the end used the useful text out of it in the post itself since it was only two lines) and the site says that .fbx isn’t a permitted filetype for uploading.

I’ve been testing importing basic (cubes etc.) models from Modo 701 (service pack 5) and while more of an annoyance than a problem there is the small issue that when you import 2013 format .fbx files into the editor it complains that there were no smoothing groups found.

The models are actually importing with smooth/hard edges and look just fine both in the perspective viewport and static mesh editor so it would be nice if we could disable this warning in the import options. If you import a 2010 .fbx file it detects that there’s smoothing and doesn’t display the warning (but does complain that out of date formats may produce bad results). Opening my two exported .fbx (2010/13) files in a text editor shows that the 2010 file is plain text while the 2013 files are now a compiled format.

Also I should say that I’m using the Vertex Normal Toolit for Modo which allows you to set soft/hard edges akin to Maya as opposed to using Modos smoothing groups settings (I used to use Maya and this is more preference than anything) and I don’t think this makes any difference to the output fbx file but I thought I’d better say this just in case.

The other issue that I’ve had is with LOD importing. Is there any way a naming convention could be set up on the importer so when it detects multiple meshes contained within a .fbx file it can check the name of the mesh to see if it’s named LOD1…9999 etc. and know to import it as a LOD mesh accordingly.

I was attempting to mimic the instructions for LOD within Maya in Modo however I never suceeded at all. I see that in Maya you create a lod group called lodGroup1, and then you group all your lod meshes under this group.

I tried creating a modo group (group locator) naming it lodGroup1 and then putting all my meshes in this one group (and naming them mesh, mesh_1, mesh_2 etc. as the picture of Maya’s group structure shows) however on importing this all the models imported on top of each other as one big mess, and choosing to try individual import did work but of course then you have multiple assets clogging up the assset browser. I also tried parenting all lod meshes to the main mesh outside of any groups etc. but this resulted in the same issue as above.

When I open the files as .fbx 2010 format (so that they’re viewable as standard text) I see that the group locator in the text has an actual name in the fbx file of:

"Model: “Model::lodGroup”, “Null” {

and each mesh and lod mesh also in a similar manner has:

Model: “Model::Cube_1”, “Mesh” {

Which are the names I set in Modo for the group locator and meshes, so perhaps the importer could be made to look for _1,2,3… etc.

In a 2013 export the only readable bits are the names themselves (eg. cube/cube_1).

Update 30th march 2014:

I’ve since tried importing fbx containing u*x_ collision models and they work just fine so the importer is detecting mesh names for Modo so perhaps allowing it to detect mesh items labelled lod1_, lod_2 etc. would be the way to go especially since I presume the method will work for every other 3d app out there. Do you still want the .fbx files attached or are you happy enough with just the text and information I posted above?

Sciife.

site says that .fbx isn’t a permitted filetype for uploading.

Try to put it inside a zip file, this should works. :slight_smile:

Terrain looks ok in Max (is unwrapped/UV, but textures gets flipped after import.

The FBX looks perfect when imported to Simlab/Unity etc so mapping should be ok.

If I import the exported Simlab ver 6.1 it looks perfect in UE4.
File is to large for Wiki it seems :frowning:

Thanks for pointing this out, I edited my post.

I’ve exported my model from Garry’s mod and tried to import it. It worked perfectly well except… In preview Lighting on model is ok but when i build lighting model recieves no lighting at all. FBX

The current exporter from Blender has a few issues, notably with tangent mapping and correctly writing out scale and orientation. Materials are also not entirely supported I think. It’s workable, and I think most of the issues are with the exporter side of things.

Autodesk has an SDK with python bindings (Blender’s addons are written in python) for .fbx so I am hoping someone in the open source community implements and exporter with this at some point.

The Blender internal game engine is pivoting away from being a true game engine, so I think there will be a lot of potential users for Unreal if we end up with really good .fbx exporter support.

I have a file that I imported into Blender to create a basic animation to test with, then I export it to a FBX. When I import into UE4 I get a 'Could Not Find Needed track (master).

File I import into Blender

Blender File

UE4 Import File

I have a few different errors with the fbx importer as i will list them below. Sorry but at this time i cannot publicly share the files or i would gladly do so. For the most part i have imported a ton of scenes with no issues. These are actually huge scenes that have come in with great success.

Completely non optimized levels, also full of props with over 880,000 triangles and materials have come in perfectly on several occasions. With that being said i want to let the unreal staff know that the import process has definitely been improved compared to udk and I appreciate that very much. The ability to import a whole scene and test the flow of the map without wasting time on exporting individual parts and re-assembling them inside the engine because there is a vertices limit saves so much time! Thank you for this!

Although these huge scenes have been successful some very small ones have thrown some errors and ill list those below.

  1. During import i will get a message display saying that no disc is in my D or F drive and it is impossible to close this message box. As soon as you click it will just ding and re-appear.I have to use the task manager to close UE4. I have a screen shot for this.

  2. The importer just crashes few seconds into the import

ASUS CM6870-US011S

Intel Core i7-3770 3.4GHz
64 bit Quad-Core Processor
Cache Per Processor
8MB L3 Cache
Memory
16GB DDR3 1600
Hard Drive
4TB 7200RPM

Graphics
NVIDIA GeForce GT 640 3GB

Windows 8

Motherboard
Chipset
Intel H77

Intel Core i7
CPU Speed
3770 (3.40GHz)
L3 Cache Per CPU
8MB
64 bit Quad-Core Processor
Max Turbo Frequency 3.9 GHz

Graphics
NVIDIA GeForce GT 640 3GB

Memory
16GB DDR3
Memory Speed
DDR3 1600

Hard Drive
HDD Capacity 4TB HDD RPM 7200rpm
HDD Spec
2TB x 2

.

There is a Blender developer who’s working on these issues.
You can download the most current fbx exporter Add-on (still WIP) here.

It supports tangent export, as well as scaling on export.

Thanks for the reply! I did notice that this version fixed some of the issues just like you say.

I’ve rigged my character in 3Ds Max, starting from a Base Human CATRig and I’m receiving an error when importing into UE4: Multiple Roots are found in the bone hierarchy. We only support single root bone.

I was able to import it into UE4 by linking the HumanPelvis to the HumanBase directly in the schematic view, though doing this feels like a hack, and Mixamo’s tools really don’t seem to like it.

Additionally, this exact FBX loads fine in UE3.

I also stumbled onto another workaround: Import the offending FBX into UDK and re-export it from UDK. This FBX worked for me in UE4.

Hi @Grogger,

We had a look at your mesh and found that you have 4 root bones listed. The pelvis, 2 feet, and Character001. You have to redo the hierarchy to one root bone. However there are still several other issues you will have to address after this is accomplished. re-establishing the hierarchy will at least allow you to import to UE4, however. I hope this helps!

Hello,

I looked at the model in 3DsMax and can see that the UVs are all off the map for the cylinder inside the tunnel. Without the UVs properly places, lights will not render properly. I added an updated version of the asset with the map adjusted. It still has overlapping UVs (something that you will have to fix in a modeling program), but it picks up light. Test

Cheers!

Thanks for the response Adam,

I’m not too savy with modelling, though I believe the two feet and the Character 001 are controllers. They were created by the Human CATRig if memory serves, and I don’t think I can remove them without breaking the Rig (correct away if I’m wrong, but I don’t know how I’d animate the legs without those controllers)

Any idea why importing into UDK is successful and why UDK’s export of the same model works fine in UE4? It would be nice to have UE4 make that same conversion to allow for the default 3Ds Max CATRig.

Thanks again

Hi Grogger,

I am looking into issues with the importer. Thank you for reporting this change from UE3 to UE4. I am glad that you have found a work-around, but I have also reported this to our developers so that it can be fixed.

Thank you,

Alexander

Any idea why importing into UDK is successful and why UDK’s export of the same model works fine in UE4? It would be nice to have UE4 make that same conversion to allow for the default 3Ds Max CATRig.

To answer this question. UE3 had a tool to auto-fix the hierarchy for the model. When you exported from UDK, it kept the fixed (one root) hierarchy, allowing it to be imported in UE4.

Hi, Alex told me to post here my problem importing Fbx, im using the same Fbx that i use in UDK (i say this to exclude problems that UE3 has too), so when i change to UE4 i tried to import the same models but crash always that i check “Import Materials”, if i uncheck it then imports well the model and the textures. I realize that the model (because its not mine) has a multi/Sub Object with Standard nodes linked to a texture, i try to delete all to ensure that there arent 2 materials with the same name, but crash anyway,

And i realize something, i see that the model uses 28 material with just 5 textures, because for example, the hair uses 5 material with 2 textures, and upper boddy 6 materials with the same texture, but when i imported in UE4 the engine detects that the mesh uses 28 materials but UE4 (UE3 too but with UDK didnt crash) makes like a joint so if the materials of heads are 21, 22, 23 and 24, if you apply the material just for 21 material the editor applies to all of them. Its hard to explain it but if i make the materials by my own in UE4 and select material 21 and apply to it the hair material , it not necesary to apply it to 22, 23 and 24

I am working with blender 2.7 and the model animation is messing up and i get these warnings FBX bind poses ‘BIND_POSES’ is invalid. it will be ignored. minimum Bones size too large. any one knows what i’m messing up

Here are my files:

I get a similar thing with Modo. I had created a cube and put a coloured material on each side and exported it to .fbx. The fbx imported fine (amazed that even the colours came along since they weren’t textures).

I then added a texture to one face of the cube, editing the fbx itself directly in Modo (because I hadn’t noticed Modo had switch to the fbx file). I then tried importing this file and UE4 crashed as long as import materials was checked.

If it was unchecked then the textures came in without issue, but of course no materials were created by UE4.

After realising what I’d done I modified the materials/textures directly in the modo scene file and exported out to a new .fbx file and imported that (with import materials checked) into UE4 and it was perfectly happy with it and created the materials and imported the textures without issue.