[Epic Official] FBX Import Reporting

Hello, I am trying to import 3d objects from Zbrush to 3ds max 2011 and into Unreal Engine4. I am able to get my mesh into 3ds max 2011 but I am not sure how to go about updating my FBX exporter from 2011 to 2014. I am given the link from Autodesk: Autodesk | 3D Design, Engineering & Construction Software but they don’t have any 2011 copies.
So, I use the FBX exporter in 3ds max 2011 and it imports into UE4 but without the textures I have assigned to the mesh. I am including my little figure into this message just so you guys can see. I tried importing just the mesh and then applying the texture after but it didn’t match up with the mesh and I am not sure how to re-adjust it.
Well, I can’t seem to show you guys but it sucks:(

Have you imported from Blender before just as a static Mesh? If so start with that first. From what I know about armatures in Blender I’d import the character using FBX remembering to scale the scene by 100. also set the batch mod to scene and check selected objects.

I am assuming and I don’t know because I have not attempted to do this but can you not save your animation as a bvh file and UDK will import that as an armature? If would be two separate imports would it not?

Remember to put your pivot point at the base of the feet with everything centered on the XYZ or the rotation will be all messed up. I was reading yesterday that edge split modifier should be applied and applying modifiers on export should be enabled. You’ll get texture and material errors as well as FBX being too old but the model should import and you can reapply textures from UDK 4.

Yes i have imported meshes fine, even importing a character without any animation works fine it’s jus the animation

I’m having a problem with smooth groups sometimes they work fine other they seem to just randomly decide to throw in hard edges here’s an example:

Normal import options comparisons

  1. is imported as a skeletal mesh with calculate normals
  2. is the same but imported with import normals
  3. shows the mesh in maya
  4. shows the hard/soft edges

I’ve exported the mesh from Maya with smoothing groups, tangents and bi-normals and triangulate checked.

You can find the exported mesh here:

Exported Mesh

Let me know if I’ve missed something as this happens with a lot of the meshes I bring in… but not all of them so I’m quite confused

It’s me again with almost the same problem here’s preview lighting http://SSMaker.ru/c8b80a2c/ and here’s final lighting http://SSMaker.ru/578280ca/ .
I dont know how to fix overlapping textures, can anyone help me?
Link to model

Overlapping UV’s are corrected in your modelling application. In Maya you can open up the UV Texture Editor and correct any issues manually.

UV Overlapping

First toggle UV shaded display and you can see where any overlaps that are occurring by the color that the faces show up as.

dark blue means there are overlaps occuring

red means the UV faces are flipped (used when mirroring)

purple means that you are overlapping with a flipped faces (also used with mirroring)

It should be noted that I believe static meshes have been setup so that they expect no mirroring (due to lightmaps) and that if you have mirroring on your static mesh you could try creating another UV set without mirroring and set that one to be used for lightmaps but i have yet to have a look into how this is done.

As an update, out lead importing programmer has prioritized this issue.

Thanks for the update Alexander, I look forward to seeing this one, since many of my characters were rigged the same way :slight_smile:

I’d also like to point out this problem on the AnswerHub I think its got something to do with Maya groups but here’s the link to the question:

FBX Related Question

Hello. Imported this FBX into 3DS MAX from Mud Box

And the from 3DS MAX into Unreal Engine 4. It was FBX (2013) ACSII. The imported mesh looks like this.

I am probably doing something wrong, rather than it being an actual problem with the importer. If so, let me know, and I will head back to the forums. Thanks!

can you show what import options you are using? ie import normals or calculate normals

Import normals and everything is checked.

I think its the same problem that I’m having with import normals; your polygon density is just a lot higher. Try it with calculate normals instead and see what you get

It’s really ugly that way and I would put up with it, but I found a solution!

Imgur

I imported it into 3DS Max and then exported it with smoothing and then imported it into unreal.

Good afternoon. I have exactly the same problem, but not in CAT rigging and simple bones. In schematic view hierarchy is built so that all attached to one Root bone, but at UDK when importing still write error "Multiple roots found "

im having a major issue whenever i try to import any model with its textures on as an fbx for some reason it puts the spec map into the diffuse channel and doesn’t even plug the diffuse in i know its a small problem but when you have 30 plus assets it can be a real irritating thing.link text

its a hit a miss thing. some models will work and others wont. exported from the same program with the same options . like for example for me certain exports from "jmc2obj a java tool to export parts of a minecraft map to object files then importing it into maya then as a fbx will cause the game to crash.

it happens often for me based on what models are being used

sometimes too a model that looks fine in say 3d max or maya will import as a fbx with textures looking weird. a better way to import the set textures/materials would be nice…

Here is problematic mesh import issue, when you export from modo and import to Unreal.
For comparison there is exactly the same mesh from 3ds max.

The issue lays in imported vertices count. When importing mesh from modo it is 1058 vertices. When importing max fbx, vertex count is 323.

But! When I import modo mesh, to max, and then export it from max as fbx, it will import correctly to Unreal.
I narrwoed issue to Preserve Edge Orientation and Split per-vertex Normals, if that option is checked in max while exporting, mesh will import to Unreal with incorrect vert count.

Preserved Edge Prientation only affect mesh, when there are turned edges.

I don’t know if that is modo issue or Unreal. I reported it to Luxologu, but after 5 updates there is still no change.
Maybe you guys can talk them over or fix it on your side.

Modo mesh import issue