Download

Enabling Nanite deform and breaks modular mesh

I’m converting a scene I made from UE4, but one of my modules breaks when I turn on Nanite. You can see the before/after comparison here. A whole piece of the mesh gets ignored and the module doesn’t fit with its neighbour anymore. I tried changing precision and proxy triangle percent but it didn’t help.

You’ll want to adjust the position precision. Also, an important note from the documentation:

Quantization is a form of lossy compression, and lossy compression is particularly challenging when working with modular mesh pieces, or other meshes that have shared boundaries. Especially if those boundaries need to align perfectly to not introduce holes, or cracks, in the geometry. To ensure consistency, the quantization happens in unnormalized object coordinates centered around the mesh origin. This ensures that the quantization never causes cracks when the mesh uses the same precision setting, and the translation between the mesh centers is a multiple of that precision.