Emissive materials lack colour

I read that the tonemapper in 4.15 changed the way bright objects are handled, and all the solutions and workarounds are from 2017 with threads saying they no longer work. If I have an emissive material that’s sole input is 3,0,0 it shows up as white instead of red, and has white bloom. I understand why it’s happening, but it’s not looking good with my stylised art as I have no control over it. What can I do to either have the emissive material be coloured, or keep the seemingly white material but have the bloom be coloured?


I’ve never run into this problem… emissive works fine…

Can I ask how strong the values are? Not bright enough for bloom so I would assume roughly under 2? Maybe even 1 at most? That works perfectly fine in terms of having colour of course, but doesn’t have any bloom. Will your material remain red if your values are in the ballpark of 3?

Multiplier 3.
I didn’t turn on bloom in PP!

With the basic bloom turned on…

Interesting. Is there anything special about your project or material setup?
For example, here’s an example from documentation:

And here’s how it looks like, recreated 1:1

These are not my screenshots, but they give you the idea. For me, it’s even worse - there would be no hint of yellow in the material itself or the bloom surrounding it.

Nothing special… I think it’s the same setup…

Made a new material, didn’t touch anything in the details and added these nodes. This is what I get - no overexposure or anything weird.

Next up I add red emission x 3 and… well.

…this is what I get…

Okay, there might be something seriously wrong with my copy of UE, or with the project itself. No idea how to narrow it down, but I have zero plugins enabled apart from plugin browser-plugin itself. Reading older forum and answerhub posts indicates others have this issue as well… Thank you for the screenshots, I’ll try to figure it out.