Emissive Material - Light Baking with GPU Lightmass Bug?


I’m experiencing some strange behavior with Emissive Materials while I’m trying to bake them.
(UE 4.27.2, GPU Lightmass) In some cases, the emissive light isn’t contributing to the baked lighting at all.

I’m testing with 2 different materials: Default Lit / Unlit, both with ‘Used with Static Lighting’ enabled. Both materials have the same Emissive value, set to 10.

Then there are 4 meshes: Two default cubes, the left with the Unlit material, the right one with the Default Lit. Followed by two imported meshes that have more than one material slot on them. Again, left with Unlit, right with Default Lit.

Right now it seems like the Unlit material doesn’t contribute to the baking process as long as there is no other, additional material applied to the mesh?

Did also a quick test within a new project and with two different cubes, both created outside UE. (with one and two material slots). Even there, if the mesh has only an Unlit material applied, it doesn’t contribute to the baked lighting.

Top Left: Default Lit
Top Right: Unlit
Bottom Left: Default Lit in 2nd slot
Bottom Right: Unlit in 2nd slot

First material slot at bottom cubes is Default Lit; same as the surrounding walls. Having two slots and both filled with the same Unlit material doesn’t work either

Don’t know if this is a bug and the Unlit-only cube should indeed emit light onto the wall or the bug happens with the cube on the bottom right and the Unlit material should not emit light at all. Third option: There is no bug and I’m simply missing an obvious point. :nerd_face: