Download

Emission Glow Change

I’ve noticed that the way emission is handled with materials has changed significantly between 4.14 and 4.16.

Here is a very simple material in 4.14:

And here is the same exact material in 4.16:

ed7defb96541887c5551a934076175ede789d2c2.jpeg

I want to get the behavior that I see in 4.14 to occur in 4.16. How can I go about not getting the emission to turn white for values above 1?

Basically I was using this to get a very large bloom effect on some materials while still keeping the object itself a very bright red, but now in 4.16, that same object is turning orange-ish white with red values above 1, but a value of 1 has no bloom, and actually the value of 10 in 4.16 has very little bloom compared to 4.14.

hey hey! Please search the forums first next time :slight_smile:
Many people share your frustration.

Have you tried giving a diffuse color AND an emissive colour?

I’m just thinking this through, surely you want the object to have a color (diffuse) and for it to emit light (emissive), if so - then give it diffuse and emissive values?

The material is unlit, so it has only emissive

Need to add a constant, and a multiply in order to get close to the old function.

I was able to find a workaround here. Adding this to DefaultEngine.ini brings back the old bloom:


[/Script/Engine.RendererSettings]
r.TonemapperFilm=0

It doesn’t unfortunately, we’ve already discussed at great length that even with that setting the effect isn’t reversed.

I mean it may not be perfect in every case, but I am getting the result I was getting in 4.14 in the example I provided. Albeit I had to crank the brightness 10x.

6f0d0e1945db42e6799d974ce3af1109bffd5282.jpeg

What is Albeit? Also how did you achieve that effect? I used the tonemapper 0 command but it’s nowhere near what you got. My blooms still go to white and the overall bloom size is almost nothing

Albeit is a word that means “although”. It’s not a gaming term, just an English word.

Setting “r.TonemapperFilm=0” in the DefaultEngine.ini as MathNerdProductions said only seems to work for UE4.15. After 4.15 I think they made the tonemapper change permanent. And as he said, you want to multiply the value to 10 times what it was before so in 4.14 where I used a multiply of 10, I now have to use 100. It’s not an exact translation to the same tonemapper as before, but I think it’s the best of both worlds as it allows for the extra bloom and color, but it makes the emissive look more realistic.

Just add the r.TonemapperFilm=0 to the first line of your project’s DefaultEngine.ini

This needs to be fixed.