Editor crashes when adding a sublevel

This was occurring in 4.13, so I upgraded to 4.18 hoping it would fix the issue, but it did not.

I have had a persistent level with 2 sublevels for quite some time (which get loaded with BP). I recently duplicated one of the sublevels, changed some things around, but when I try to add it to the persistent level the editor crashes.

I was able to use the UE4 menu Windows->Levels->Add Existing Level to get it added to the persistent level without the editor crashing. Gameplay worked as expected, going from PiE back to editor several times.

However when I later opened this project it crashes when I try to load the persistent level.

I fixed the persistent level by renaming the sublevel, so that the persistent level then had a broken pointer, which allowed me to load the persistent level. If I again tried to drag+drop a level from the Content Browser into the Levels menu (to add a sub level to the persistent level) the editor crashes.

Only thing here I would guess at, is that since I duplicated a sublevel many of the objects in it would share the same name as objects in the other sublevel. But that can’t be what is causing the crashing.


We’ve recently released a new method for bug reporting using a more structured form. Please take a look at the forum post linked below and submit your report using the new Bug Submission Form.


Have a great day