Download

Editor Color Picker BROKEN Disappears in Niagara Curve

I dont know how this happend. The last thing i done enabled the raytracing in project settings. After restart and recompile the whole project and some crashes, i wanted to work again with my Niagara Setup. But suddenly i cannot select a Color in Niagara Particles via Curve Parameter. if double clicked nothing happen. When i click right → Choose Color, The Window appears for a sec and then disappears again. I tried a new EMPTY (without raytracing) Project with 4.26. Same behavior. I tried to restart/uninstall /Verify the Install Still the same Problem. In Version 4.25. the Color picker works… I dont know what to do, i have to get the color picker there… What can cause the Problem?

Here you can see the Problem. Niagara Color Picker BUG - YouTube

I cannot work further with this bug. Highly appreciate any Problem Solving or other way to access Colors.

That’s weird… I’m also using 4.26, but the Color Picker works for me in Niagara Curves.

Are you able to Alt + Tab to the Color Picker after clicking on Choose Color? Or is it also closing as soon as it opens?

I think you should report this bug, but one workaround that could work for you is importing a Color Curve with the Import button on the top right corner of your Niagara Curve. In the Content Browser, Right Click > Miscellaneous > Curve, then select CurveLinearVector. Are you able to open the color picker by clicking on one of the colors in the gradient at the top? If not, then the bug affects more than just Niagara, but as a workaround you could still move the Red, Green, Blue and Alpha keys of the curve manually to get the colors you want, at least.

i worked with 4.26 for 3 Weeks now, also the Color picker worked till unreal decided to show me the dark side. Alt Tab doesnt work unfortunatly. The Window is not even in background it is just closing immediatly :/. Thanks for your hint about the curves. the bug appears in there as well. So it seems like the overall Curve Vector Picker got some Problems. In Light or Materials the Color Picker Window works. I submitted a bug report now but i guess nobody can reproduce that :/. Thank you for the tip with the curves. Appreciate your response.

I am using 4.26.1 is there any way to download 4.26.0 ?

I’m afraid it’s only possible to return to 4.26.0 if you download the source from GitHub and build it yourself.

Hi, I dont know if you have solved that but I got the same issue, the picker blinked to nothing instantly after clicking the button. I cannot find anything that works when the window is popped out, but it somehow works when I place it on a new tab in the main window. Hope it helps.