Download

EDIT: Solved- Which Project/World Settings Could Break AI Navigation?

I have a project where no AI pawns are moving at all.
Wondering if I’d messed up, I made new pawns in another project and noticed they were all working fine. So I migrated them, and still no go.
I do have NavMeshBounds defined and toggling preview have a map that is nearly entirely green.
I can’t seem to figure out why this specific project has all pawns stuck in place, regardless if I use Blueprints or Blackboards/Behavior Trees.
So I’m wondering if there is a way to reset navigation related data that may have been altered in the system, or if there are project settings that may commonly interfere with a pawn’s ability to navigate.
Also to note, I do have grass layers but as I’ve also tested on block platforms, they do not seem to be the issue. Player Pawn can move fine.

I am using ALSv4 for the player pawn, but not for the AI pawns. However, it may be possible that it is interfering but I wouldn’t know.

=====

I solved it. I had somehow altered the default AIController asset in the engine . I just overwrote it with a copy from one of the projects where I had been creating test pawns, and it is working now.
However, I have no clue how I could have altered that. The only engine files I have touched at all are those relating to volumetric clouds. But clearly, I did and just don’t remember how.