EA to Preview 5.0 Wasnt this suppose to be exciting?

Not sure where to put this… Going from EA to Preview, I noticed materials were broken in my project; especially Nanite bridge assets. Also the lighting has changed significantly, and I’m not sure whats wrong. Shadows are completely black and so are my assets when the sun isnt directly on them


1 Like

Rebuilt all of the materials…no change. Started a new level and dropped in the same assets… all look fine. What could be wrong?

Okay, so there is something wrong with this material… please help. This is from a bridge megascans. If I drop in another megascans material onto my cliffs its works… so whats wrong with this material which is suppose to be the right one?

Hi, I had the same issue. The default ms (Megascans) parent material was somehow modified (bug?) when updating from EA to Preview 1. I had to go through each affected material and change the parent material in the details panel from M_MS_Default_Fuzz_Material (LOL right? It uses a cloth shading model) back to M_MS_Default_Material which uses Default Lit. Hope that helps.


Hey thank you, I eventually figured it out… and that’s exactly what happened. Hope this helps others

Hello, I have recently installed the UE 5.0.0, before new version, I was using UE 5 Preview 2. When I opened my project first time I’ve encountered “M_MS_Default_Fuzz_Material was missing the usage flag bUsedWithInstanceStaticMeshes. If the material asset is not re-saved, it may not render correctly…” warning. I am not sure this is related to my problem.
My problem is:
All 3D assests looks corrupted in my level.

I’ve tried @ARMRgarden ’s solution but it didn’t work. Do you have any suggestions?
Thank you for taking the time!

Switch to MS_Default material, if using virtual textures duplicate the placeholders and make them virtual, replace the material textures with the new virtual placeholders. Hope this helps. You may have to check all of your material instances and make sure the proper textures are in place

1 Like

Thanks a lot! Unfortunately, the result is the same. May be I couldn’t follow your instructions properly. I am sorta new in Unreal.

I am thinking to start a new project and build my level from scratch.

Thanks again for your help!

That is really strange

1 Like

I ended up having other issues with my project as well. I’m still getting weird texture behaviors. I created a new project and had the materials set right, but I imported custom metahumans and some other assets and again had this bug emerge where some base materials were changed to default fur and upon changing them to default (which I assume is how they started), the materials seem to have lost some properties, like reflection/specularity etc that were present before. Anyway, I’m fairly new to unreal as well. I hope we get these issues worked out.

I know when you import metahumans there are project settings and some other things that must change in your project for the shaders to work properly right?, maybe that has something to do with it. I’m not sure yet.

1 Like

That is extremely annoying. Now I am worried about doing something wrong and ruining my project again thanks to the problematic launch version of Unreal.
Strangely, there are not many posts and questions related to our problems. I guess we are the only ones. Can’t do anything except hoping these problems fix itself in the future with new updates. I’ll let you know if I learn anything related. Thank you for replying!