Dynamic Shadows on very large landscape

Hi. I have a very large landscape, around 600x600km2, and shadows wont get any better than this, what can I do??

I am using dynamic light

Here are pics of my issue, and my settings

Do you really need that big distance? I believe it’s clamped somewhere deep in the engine, there were issues with it on these boards if I’m correct. Go with:

r.Shadow.MaxResolution X

This will increase the max shadow resolution, but don’t go above X == 4096. If that effect does not satisfy you, take into consideration your camera. Is it FPS? Isometric? How big part of the landscape do you actually see at one time? Reducing the range makes the shadow better, because it will have to fit less shadows on the same texture.

There are also several other variables in the r.Shadow section that might help you, depending on the camera / project you’re trying to do.

Also, this isn’t your regular game options slider. Going with MAX VALUE on all settings doesn’t mean you will get the best look. You have to dig deeper, much deeper to get it right.

It is fps/thirdperson,
and yes I need that distance because sometimes you see across over 50 km infront of you, and then the visible mountains and valleys don’t render any shadows at all.

But I will go inte visual studio and try your solution. And I have tried several different value settings before deciding with maxing all the values, that seemed to give me the best result.

Thanks for the tip about r.shadow.maxResolution,

Ok I changed the ShadowResolution and scaled down the dynamic distance a bit, together it works perfectly!

Thanks for the tip