Dynamic Navmesh Different in Packaged than Editor

I’ve run into a new problem in 4.21. Having some serious difficulties generating navigation meshes on dynamic terrain. The biggest problem is that after some tuning things seem to work fine in the editor but when packaged, there are seams in the navmesh that prevent AI from crossing.

These are my navigation settings



This problem is new to 4.21. Everything was working in 4.20. I did notice now that without setting to fully async, NavigationInvokers stopped working as well.

I confirmed that the seams are along the Tile boundaries. Increasing the TileSize changes the seams accordingly.

See the problem in action

Tried Switching to Chunky Monotone as discussed in this thread…

No luck. Again, things seem to work in the editor but not in the packaged build.

Also, I’ve already reported this through your the Bug Tracker. I am aware that you recently switched to a new bug tracking method. What I’m looking for here is new/unknown configuration requirements for 4.21. That could address this.

Tweaking the Cell Size to 32 x 21 and the AgentRadius to 35 made the problem go away but now having problems with AI using doors, stairs etc.

Just to confim I’m seeing similar issues using navigation invokers and dynamic navmesh. They worked fine in 4.20. In 4.21 the recastnavmesh serialization has some uninitialized variables in it when loaded (NaN etc.). This led to some infinite loops in the tile calculations and seems to be intermittent, sometimes works fine other times not.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.



Did that first :slight_smile:

Do you have a link to the issue? We are having the same issue and I would like to vote on it and track it.

I’d love to share a link with you but all I got was this…

Thank you for your bug submission. We
will be investigating your case and
follow up if more information is
needed or when a ticket is created.
You can track the latest UE4 issues at

I made a test project that demonstrates this issue.


How it looks in editor:

How it looks when packaged:

I have Exact problem :frowning: Fix Probobly will be only in 4.21.1 , Only how long we must wait. For now now Packaged Testing.

Got this email from Epic…

It appears you might not have received my previous reply to this issue. I am glad to say this issue is fixed in our latest internal build. I’m unsure when it will be officially released but you are using any of our Source Builds you can grab it from the Master Branch on GitHub. This was fixed in CL-4567513

Awesome, now just we need to wait till Launcher version got Updated. 4.21.1 , They fixed this Bug and Bug where level Streeming doesn’t regenerate Dynamic nav mesh on Mobile.

Confirmed NOT repaired in 4.21.1


Yes, It is not Fixed, however, Support told us that it is Fixed in Master Branch of UE4 … so I m confused from where does 4.21.1 comes if not the master branch … but ok I’m Downloading Master Branch will update if master Branch really fixes this Issue.

Has anyone located the commit for this on the master branch? I can’t find any comments with CL-4567513.

Thanks though there’s no reference in the comments to the code/commit for the fix.

You can read in Comments what Support Answered to a person who made bug report … https://answers.unrealengine.com/questions/848562/view.html