Download

Dynamic Lights - Contact Shadows.

Any idea on how this Halo around a static mesh can be corrected? It is somehow caused by contact shadows being set to .1


At the same time it seems to generate this very nice effect:

Reducing to .05 seems to lessen the effect - until ofc eye adaptation comes in.

ON top of that, with tessellation on the landscape this happens:

Surely, this can’t be a core feature that is built into the engine that just works this way.
Particularly the vignetting that you get when you are in a shadowed slope area.

Any ideas aside from turning it off?

I would try a much lower setting, between 0.02 and 0.03. I find that unless you have fixed camera then you can’t really stray much from that range (at least with directional lights)

Hi, Thanks for the reply.
Unfortunately .01, .02. and .03 (or just about any value) seem to produce the odd vignetting effect:

Not sure if the feature is just bugged out this way, or has always been bugged out this way…

IDK, maybe this needs a new topic.
So Shadows on the landscape look much better if you set the ShadowAmount value to something like .5
However, then your character’s hair light up like a light-bulb.

I have so many “special” settings toggled that I even forget. though I doubt any of them affect either issue:
ScreenSpace GI is on. with lowest quality and half res. the cost is somewhat acceptable but I’m really considering disabling it because 4k gets a big hit. 3ms at 2k… 7.28ms at 4k And nearly 0 benefit…

Distance fields are on, and the movable skylight should be adding in AO.

Light propagation volumes are on (though I think that’s default).

Landscape has Far Shadow on, should also be default.

These are the modified light settings:

Playing with the bias doesn’t really change the stripe effect on the landscape, and because the cascades are just 1 the other options are irrelevant.

Lowering the intensity of the directional light from the default of 10 to a value of 2 seems to have helped a little with the shadows, however contact shadows vignette effect is still ever present. The shadows also slide around for a quite fascinating effect - what a mess :stuck_out_tongue:
IT really feels like a broken feature, but I never used it in a different engine version, so I can’t be sure that this just isn’t how it is…

If anyone has any tips to get the dynamic shadows to play nicer I’m all ears.
baking 2500 tiles isn’t something I’m particularly inclined to do.

Hi, Contact Shadows are a screen space effect, so you won’t have them at the edges of the screen. I think the problem with the vignette is more that it seems that you have a contact shadow on your whole screen.

Here at minute 31 he talks a bit about contact shadows https://youtu.be/nm1slxtF_qA?t=1863

That’s true. The contact shadow is on the whole screen because the slope on the landscape calls for it and cascaded shadow-maps were disabled.
however even with them enabled the vignette effect is very visible as the csm shadow doesn’t really conform to the same rays that the contact shadow uses.

Basically to get something to look decent i’d have to spend 20ms or more on a raytraced shadow for the slopes alone…
This is obviously also true with the character halo. The reason it is present is the change in depth…
il have to find a better compromise…