Dynamic lighting artifacts on spheres

Hi,

I have an issue when using a dynamic light on spheres : on the side with the shadow/light boundary, if viewed up close, you can see lighting artifacts. The artifact consists of noticeable lines on the surface.

The following screenshot was taken in “detail lighting” rendering mode on the “EditorSphere” mesh included with UE. Copy/paste the image URL in your browser if you don’t see the issue.

I’m using UE 4.7.6. The light is a directional light.

These lines are caused by the Cascaded Shadow Maps.

You can adjust the settings in the CSM tab in the Light Source and try adjusting the Shadow Bias & Shadow Filter Sharpen for better results, but it will not necessarily get rid of this completely and changes can affect other objects in the your scene if you’re not careful. It’s about finding a balance to what’s acceptable and what’s not when adjusting the CSM for dynamic directional lights.

You can see some examples in our Wiki Lighting Troubleshooting and Tips guider here: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

Thank you!

Tim

Thanks for the explanation.

My object is very very far - It’s a background prop. It looks like CSM are only for close geometry ? Does it make sense for this artifact to happen from afar ?

I would expect it to do this at further distances.

The cascades (lines) can only be accurate within reason of performance. We do have some things coming in 4.8 that will help with this. We have a per-object check box to enable “Far Cascaded Shadows” that can be enabled for those objects that need shadows at further distances.

I’ve not used the feature really yet so it may be accurate for your needs there to help out.

We will be going into our preview releases for 4.8 very soon. So it would be worth it to give it a shot in that.

If you give me the scale of the mesh and any settings you’ve changed in the directional light, I can test this out with the basic sphere mesh in the editor and see where I could offer some tips to get better results.

Let me know.

Tim

Hi Tim,

I can’t get this far shadow thing to work.

I’m now using 4.8 Preview 3. My sphere is 80000 units away with “Far Shadow” ticked, my light has values of DynamicShadowDistanceovableLight = 50000 and FarShadowDistance = 100000, with 3 far cascades.

Nothing appears to have changed. What did I miss ?

Far Shadows is working for me when I’ve tested this. However, I believe you’ll still run into similar issues because this is using very large objects at very far distances. There will be limitations with the cascades to keep things within reasonable performance levels.

With the limit on cascades to cast over such far distances there will be things like this. If this is a background object and doesn’t need to cast a shadow on anything. For instance, a planet where a ship goes below or behind it, then you can just uncheck the cast shadow option and it will still cast a shadow on itself for parts of its mesh, but it will not cast a shadow on anything else.