Dotted image

Place a post process volume into the level if you dont have one already, set it to Unbound to make it global and then tweak Ambient Occlusion parameters.

I just want to know if this is normal or not:

Because it’s certainly looks wrong to me. Is there a way to make image clear and get rid of those “dots” in shadows?

Set Quality to 100. That’s about as good as it gets. If you want to get rid of AO all together set intensity to 0.

Well, no, I don’t want to get rid of AO… And changing quality doesn’t do anything at all.

Is it how AO supposed to look in UE4? I highly doubt it…

Yeah, I have global post process volume on my scene. And I tweaked different parametres of AO, but nothing gets rid of those dots in the shadows.
Here’s another screanshot with AO settings:

I tried all the switches.

And if I turn off anti-aliasing, it’s even more visible:

What is Engine Scalability Settings is set to? Make sure it is set to Epic.

Hey Kligan,

You wouldn’t happen to be using Distance Field Ambient Occlusion as well? This is enabled by using a Movable Skylight with Cast Shadows enabled.

You were right - I had some scalability settings set to high instead of epic.
On epic it does look somewhat better. However, mostly it’s due to getting anti-aliasing cranked up to maximum.
That’s what makes me wonder though - the problem isn’t solved, it’s just the image getting really blurry when AA is set to epic.

No, I don’t have Distance Field AO enabled in my project settings.

Make sure Resolution Scale is also at 100. - yep, it is set to 100 and it was always.

Have you tried FXAA method instead of Temporal AA? And can you upload screenshots with those AA settings please?

I don’t think it has something to do with AA. It’s just different types of AA blurs the image differently. And the more blurry it is, the less you can see the details i.e. dots in the shadows. But they are there regardless.
Here’s how it looks with different types of AA:

The first one(Default AA, that is Temporal AA, with Epic quality) looks normal to me to be honest. I would try different AO radius and intensity values to prevent AO from smearing too much and thats it really.

Could you please check if you have the same dottiness in the ambient occlusion with AA set to medium or disabled? I just want to know if it’s how it is suppose to be or I’m getting something weird here.