DOF edge artifacts on foreground objects

Hi There,

I’m using a Cinematic Camera and can’t seem to solve this. I’ve tried everything but the edges won’t go away! It seems to be most apparent on foreground objects that are out of focus. Does anyone have a suggestion about how I could fix this?

Thanks,

Dan.

I’m curious if I’m the only one experiencing this or is it a know issue with the engine?

Thanks.

Hey Dan.
I have the same problems. Already any solutions? Thanks!

It’s probably faster to get a response or solution to re-post this, and post it in the Rendering sub-forum. It’s showing as having 1 answer, which could imply to some that it’s solved.

Still no solutions at this point that I’m aware of… :confused:

Hi Dan, I’m having the same issue.

Hi,
I found this tread and it is the only place I have found people with the same issue I’m facing. Does anybody know any solutions for it yet.
Thanks!!

Hey guys, we found a one solution, make sure all of your particle and mesh material, go to Translucency

Accidentally found a solution for this issue
Use console command: r.DOF.Kernel.MaxForegroundRadius 0.003.
0.003 is the value that works for me, the default one is 0.025. Just decrease it until you are satisfied with the result.

3 Likes

This fixed the issue. Thank you so much!!

I just posted something similar and i will try this solution, getting some hard time here to figure out how to clean edges out of focus.

https://forums.unrealengine.com/t/movie-render-has-focus-artifacts-when-close-and-focused-on-small-objects-not-present-in-high-res-screenshot/

Well, it removes the strange blur indeed, but the bugged edges are fricking there…

Hello!

The solution might be to turn off the DOF render of the material shader, it makes the engine to render the translucent objects in another layer, so turning it of could solve the problem

Hope this helps!

This option is not enabled for me to change:
Captura de tela 2022-08-10 225815

I am using the master material from Quixel

If the material has translucency you should be able to chance the Translucency pass to before DOF or After motion blur

image

image

hope this helps!

Ty for your reply.

I cannot change this option if the material is set on Blend Mode to Masked. My guess is that is a limit of the engine, really low Aperture for really close shots.

It helped me. Thank you.

Sadly this is still the answer for me, just a limitation of the engine’s quality at extreme close up detail that begins clipping basically like any other 3D program. It’s either that or as somebody else said run DOF through a post-processes in dif program afterwards

Thanks! This works as a workaround, still wondering if there is another option to get higher quality DOF for close objects.
Its not a material issue, tried it with several different materials, including the most basic shader.

This command basically just tells the engine to not blur the foreground objects too much, which is what causes the artefacts.

I also noticed that the objects closer to the camera did not have proper DOF.
In real life, a cine lens focused, let’s say at 20m, would have the object that are closer to the camera in an out-of-focus/soft, much more than UE does, for both wide angle and tele lenses.