Dither Temporal AA is noisy

Hello. I have successfully used the dither temporal aa node to make the border area translucent, but when I look at it up close, I see that it is a bit rough. Is it possible to smooth this out so that the dots are not visible?

First I tried changing the anti-aliasing method in the project settings, FXAA, TAA, MSAA, TSR, but none of them made any change.

Next I tried changing the number of TAA samples with the console command :

r.TemporalAA.Upsampling 10 (default was 1)

But nothing changed.

Finally, in the movie render queue output settings, I set the anti-aliasing Temporal sample count to 32, but there was no change!
スクリーンショット 2022-06-18 162521

what should i do?

My version is 5.0.2. Material graph is same as this post (Can't make the shaders as per the tutorial)


1 Like

I’m 3 months late, but that looks to me like your DitherTemporalAA node has its random pin left at the default value of 1. Attaching a constant 0 node to the random pin should make solid bands.

…I should say the 21 hour render is for 1049 HD frames, not for a few frames of fade!!!

So I’m several months later, and have spent what feels like countless hours trying to solve this problem!!! My knowledge is limited, but I have set off a render with a spatial and temporal sample count of 10 each, having also set the random pin to 0 as you say. It appears so far (it’s a 21 hour render!!!) that the fade seems much much smoother this way.
I don’'t know whether setting random to zero helps, or whether it’s the spatial or temporal values that do the trick, but it’s something to look at if you’re having this problem.
Feels like a ridiculous issue to me, and it was very embarrassing not being able to sort this when my client needed a simple fade!!!