Distance Field Shadows not working with directional lights

Ray traced distance field shadows works perfectly using point lights but as soon as i am using directional lights i am getting no shadows at all unless i use the other techniques, i do not know what i am doing wrong and i have searched the forums and used google but nothing comes up regarding this issue.

I had the same problem before.But suddenly it works,I don’t know why.

Hello Elias79,

So to clarify these are the steps you are using to enable Ray Traced Distance Field?

1.) Go to your project settings > Render > Enable Mesh Distance Fields

2.) Restart your project after saving.

3.) Go to your directional light and enable ray Traced Distance Field Shadows

Following these steps I was able to create the image above.

Let me know if you are doing any additional steps,

Thanks,

Logan

I have now tried using a new project one time using the empty level and first then with the default preset, same result with no shadows if i disable dynamic shadows by putting the distance to 0 and enable distance fields still nothing
could be a limitation with my graphics drivers if so why does it work with point lights it cant only affect directional lights right if it was a drivers issue
I am using Unreal Engine 4.8 and running on Amd radeon 280x if that gives you any info, as directional is the only thing that DFS do not work with i don’t know what to tell you, anyone else that had these problems?

And should i try with a older version of unreal editor if possible on another computer maybe?

sigh

I’m having the same problem. Followed all the steps. Ray Traced shadows are working perfectly with a Point Light, but not with a Directional Light.

I’ve tried about everything I can think of. RayTraced DistanceField Shadows is ticked on my Directional Light and all settings seem to be correct…

Not sure if it matters, but I also have an AMD card (radeon 7850)

Well it is either a amd gpu drivers issue or a problem with the new Unreal Engine 4.8 so i hope someone could find a solution soon.

Sadly same problem in Unreal Enigne 4.9 preview.

Experiencing same issues with both 4.8.3 and 4.9 preview, works fine with point lights, but not with directional lights.

Thank you, now how do we report this bug to epic?

I assume someone (from epic) will see it, Also I discovered that at certain camera angles the shadows seem to appear and flash like crazy, and at other angles they seem to work normally. This did not happen in 4.7 , in 4.7 this worked flawlessly.

Hello Elias79,

I apologize for the delay in the response,

If you would link me your DxDiag, then perhaps I can narrow down your issue.

Thanks,

Logan

link text

HI Sarr,

Thanks for replying, however I was addressing Elias79 in regards to his question.

In response to both of your issues, with only Ellias79’s screenshots, do either of you have your Engine Scalability settings set to Low.

If this is not set at medium or above then the shadows will not show up.

Logan

I figured since we both have exactly same issue that my dxdiag may have been helpful too, also someone here mentioned they think it may be AMD drivers, I have a friend with Nvidia card and he experiences same issues in 4.8 and 4.9 but shadows work for him in 4.7 just fine. I have scalability on Epic

Thank you for your reply and here are my results.

http://pastebin.com/vSM7y8ey

Hey guys,

Not a problem,

Here is what I would like for you two to do.

1.) Create a new Project
2.) Delete the sky light and skysphere from your project so that the only light in the scene is the directional light.
3.) Delete the direction light that is called light source.
4.) Create a new directional light in your project
5.) If you directional is static or stationary then you will need to rebuild your light maps by clicking build in the main viewport.

There a few possibilities for what could be happening,

1.) Your lightmaps have not been rebuilt therefore causing the shadows not to be calculated in a render pass.
2.) There is a kind of issue with the skylight and skysphere overriding the shadows of your directional light.

I will continue to do more research on my end as you are recreating these steps

Thanks,

Logan

In my main project my directional light is dynamic, and I’ve tried removing every other light, and even the skysphere and rebuilded the lightmaps, still the same issue,

in a new project, removed all lights and the skysphere, added dynamic directional light, set GenerateMeshDistanceFields, restarted editor, rebuild lightmaps. still no raytraced shadow, I can visualize the Mesh Distance Fields and see them.

Yea same problems here i tried these steps and before this i used the Distance field test file provided by Tim Hobson.

55572-df_test.zip (2.52 MB)

I have yet to try using unreal engine 4.7
as im out of space on my system disk drive so im wondering if can i install unreal engine 4.7 on another hard drive?

Hey guys,

I apologize for the delay in answer. Another support team member found that this is indeed a bug.

It appears to be an issue with that particular series of Radeon graphics cards.

In the meantime a possible work around is to use a point light for specific shadowing that fits your project needs.

This issue is currently being looked into by our development team. The bug number is UE-20358

Thank you both for reporting this issue,

Logan

I’m having the same issue on a GTX660M