Distance Field Shadows Issue HELP!

Hi all,

I’ve been doing dynamic lighting in Unreal for quite some time. However in 4.25.4, whenever I enable Distance Field Shadows in this house, this happens (See Image).
The shadows seem to lean on one side towards the Y axis? Then there are strange artifacts.
My map is fully dynamic with Static Lighting turned off in Project Settings. No precomputed lighting is checked. Distance Field Shadows is enabled of course. No 8-bit Distance Mesh fields, no compression.

I’ve tried:

  • increasing Resolution Scale on meshes (floor mesh, wall mesh, etc)
  • toggling all light options in details for point light
  • switching between static, stationary and movable (movable preferred)
  • increasing/decreasing shadow options and mesh distance field options
  • using regular point light and spot light not within a blueprint actor
  • disabling surrounding lights
  • changing materials on mesh/ using basic materials

Even though I have already messed around with the meshes themselves and tried changing some settings, I have a feeling it could be an issue with the mesh or perhaps materials?

There is also some shadows that do appear correctly but its obviously showing mostly shadow artifacts with DFS on

SOLVED: This house was a mesh asset off marketplace. Lesson learned here is watch out for large exterior meshes covering smaller meshes with DFS enabled. There is a very large mesh covering the entire interior of the house that required a very high resolution (100+ scale) or needed to be turned off. Once I tweaked that, Boom. everything looks great. I know some people struggle with this too so hopefully my answer to my own question help some of you!

Distance Field Shadows Enabled