Disabling postprocess per level

Is there way to disable Eye Adaptation in just one level. It’s a VR experience and I’m struggling to achieve 90fps in one level and since the lightning is constant, disaabling eye adaptation should help with some microseconds. I’m looking for similar effect achieved by “r.EyeAdaptationQuality=0”. I know i can se the variable at start of level and then have some sort of universal switch to restore it. But i’d like a more ‘clean’ solution, if there is one.

Add a post process volume to your level and tick the “Unbound” property. Then under auto exposure, set the min and max brightness values to 1.0.

It’s not going to disable it in the project settings, it’s just doing what you asked, disabling it via the post process of the specific level. Setting the min and max to the same value turns it off because there’s no more blending from one brightness level to another.

i did that, but it still seems to be active in ProfileGPU :confused:

My ProfileGPU looks like this after setting the values under auto exposure … so it seems to me it still takes some power.

That’s beyond my knowledge unfortunately. All I know is that setting the min and max brightness will essentially disable it but that’s just disabling the effect of it. It’s not going to affect the rendering cost. I think the only way to get rid of the rendering cost is to disable it in your project settings.

Not sure if it is still relevant, but I had to adjust the min/max sttings in the settings of my camera as well.