Disabling "Apply Fogging" Doesn't Work For Translucent Shader With Volumetric Fog

I think this was working in 4.18, but as far as I can tell this does nothing in 4.19. I have some particles that I want to use to distort the scene, but they receive fog from the volumetric fogging and make the fog appear to be doubly thick where they appear because even though “Apply Fogging” is disabled, the fog is still applied to them when Volumetric Fog is enabled.

Is this a bug or a known issue? It prevents many possible visual effects with particles or other translucent objects.

I’ve just run into this too. Seems to be no way to stop something from having volumetric fog drawn in front of something. You should log it here if you haven’t already: Unreal Engine Community

I submitted the bug, but they say they cannot repro the issue. We fixed this internally with some shader code fixes, and due to deadlines I can’t submit a sample project in the near term. Just wanted to update you.

Thanks, I logged it again with a repro map. And here is an image to make this thread prettier.

[repro content 4.20 preview][2]

Nicely done! Thanks for following up on that!

Issue link: Unreal Engine Issues and Bug Tracker (UE-61551)

was just looking into this, apparently the issue has been updated to “by design”

Huh, by design?? That seems very odd since it makes the fogging unusable in certain scenarios and was fixable by our graphics programmer. I can ask him how he fixed it if it might help others here.

Have you solved this problem?

Imagine you want volumetric lighting but you have a space scene located on the moon and the exponentialFOG threat the space skybox as any other skybox, well i want the skybox to be completely excluded but i can’t

I’ve just ran into this problem and was not able to find a solution. If you could share how you fixed it I would really appreciate it.

For those who want to know what we did, we made this change to BasePassCommon.ush

Hey rujuro,

I could use some more direction on how to implement this. However I try to include it into my BasePassCommon.ush it just makes my engine crash when trying to load.