Disable terrain smoothing?

Is it possible to disable the smoothing/shading applied to a terrain so that the edges are sharp. I’m going for a deliberately low-poly style, which is easy enough, but it has gouraud shading where as I would like my terrain to look similar to:

Changing world position offset normals - Rendering - Unreal Engine Forums helped me.

In your landscape material, place a world position node, split it to DDX and DDY and input them in a cross product node which inputs in the final normal input.

Like this


The result on a high poly landscape

I’ve found that the technique suggested by @Knasterband produces some very dark shading in places that should be relatively well lit. In the following images the directional light is perpendicular to the terrain. The terrain on the left is what I got using @Knasterband’s technique, the terrain on the right is what I ended up with after some trial and error:

I spent a bit of time trawling the docs/answerhub for clues until I realized that the generated normals were in world space but the Normal input on the material expected them to be in tangent space, thus the generated normals had to be transformed to tangent space using a Transform node like so:

mAlkAv!An on the forums just pointed out that a better way to fix my original problem is to simply untick Tangent Space Normal in the Material properties/details, that way the Transform node will not be required.

Is there a way to do this, in mobile? DDX and DDY is not mobile compatible, have someone found a turn around?