Different lighting between same objects

I’ve been wondering how to make two meshes lighting seem smooth with an obvious line separating two colours, like in this photo:

I basically have multiple models that “box” in with each other to make a tunnel without having to do the whole thing in another software. In this screencap, my models all have Uvs and a lightmap resolution of 64. Any solution would be extremely helpful,

Thank you

You need to see fi all the models are perfectly snapped and aligned, and no overlappings. After that, if are everithing right, you can change the light settings in your world settings, try to increase the quality to 6 and decrease the smothness for 0.75 (if you see bleedings in your lightmap, keep lightmap smoth to 1 or 1.25), and increase your sky bounces and indirect lighting bounces may help too. After that maybe you scene changes a bit, but you can return to the same actual results setting up your light actors.

Where are you seeing the quality? The only quality I see when looking at the world settings is Indirect Lighting Quality. I have the same issue as the OP and everything else you said didn’t seem to work unfortunately.

Is exactly what i’m saying, i’m sorry for not be specific, you need to expand this menu to see all the options. And remember that every time you change some setting in world settings, you need to recompile the light of your scene

(Don’t just copy it, world settings is relative with your scene)

to be honestly, have a lot of things that need to be improved to have nice seamless shadows and lights with modular structures, with a nice lightmaps, without bleedings, but the most thing that happens, is that you light build scale doesn’t matches with your object scale, and don’t had space enough to build a good lighting and shadows. So, what the scale of your boxes in unreal units? You can meassure it using the grid in top or ortographic views, if you have too small boxes, you need to decrease the lighting scale and rebuild lights (i guess that is your problem), so first try to decrease to 0.3 or 0.5 and rebuild lights to see the results (this can make the lighting built needs more time to compile) if this doens’t work, try to increase the box lightmap resolution in your mesh settings to 128px or more and rebuild to see if this made some diference, you can see the resolution of you lightmap in the scene by pressing Alt+0 and return to lit shading using Alt+4. So let me know if this make your scene looks better. When i work with small modular pieces and i need to have lightmap without this “cuts”, i increase lightmap resolution, or just reduce lightmap building scale in world settings usually one of this works. Let me know if this works.


Unreal when builds lighting it calculates lighting per object this is why you get with these settings shading differences!
SLLS: 0.1 - 0.15
ILS: 0.6
and you’ll get rid of those!! :wink:

…I would turn off lightmap compression (and AO too till you don’t get your lighting right).
Also 100 bounces are pointless: above 10 it’s just random and can produce false results… just keep it between 5-10!

This fixed it for me, thank you so much!