DBuffer Decals corrupts the file

Hi, It’s me again with another issue and please help if possible.

I work on this little project learning UE on 4.11.5 version. I wanted to put Decals on the walls and I had that problem where the decal wouldn’t show or wouldn’t render if it’s not hit by a direct lighting. Searched on forums about it and found this bug report that is closed and I thought it should’ve been fixed. This is the link:

If you scroll at the end of the page, there is a post of how that rendering on decals that should work is explained. So, following those instructions I ran on a bug.

Now my bug:
In Project settings:

  1. Under Engine > Rendering > DBuffer Decals > click on checkbox (Click Restart Later).
  2. Under Optimizations > Early Z-pass chose Opaque and Masked Meshes from the Drop-down menu.
  3. Under Movables in early Z-pass click on checkbox.
  4. Restart the UE Editor.

Note: While the project is initializing, it stops at 45% and it gets stuck for forever.

I started a fresh project from start and did the same steps and the same thing occurs. Initialization stops at 45%(on my PC).

Please tell me if there is something I can do on my project to make it work because I’ve spent 2 weeks on it (Even though learning stage) but I would like to continue with it if possible. I can put a zip file of the project to download for you guys if needed. Maybe there is a way to undo those checks on some file with text editor but I don’t know where. I will start all over again if it’s corrupted for good not that much of big deal, but if possible, would like to work on the same.

Hi Bekim -

I am not getting any errors using Preview 5, but lets first get you back into your project.

  • Open your Project’s Config Directory and the DefaultEngine.ini file.

  • Look for the following lines of code in the ,ini file:

    [/Script/Engine.RendererSettings]
    r.DBuffer=True
    r.EarlyZPass=2
    r.EarlyZPassMovable=True

  • Remove the three lines from above (the ones beginning with r.) and save the ini file. (This can be done from any simple text editor like Notepad.)

  • Restart your project

Now that should get you back into your project, can you post a copy of your DXDIAG?

Thank You

Eric Ketchum

Thanks for the reply Eric, removing those 3 lines made everything work. However, on my PC the same problem remains if those lines are on and, I can’t use the decals unless I use that other trick to put the texture on Emissive. I attached a copy of the file you requested, hopefully it will help.

link text

Hi Bekim -

I want to rule out a known issue with laptops using intel integrated and discrete graphics cards. Go into your Nvidia Control Panel and make sure you set UE4Editor.exe to use High Performance (always use the Nvidia card instead of the intel integrated graphics card. You also want to make sure that you have no settings which force all programs to use the integrated graphics cards with, for instance, a low power mode.

Once that has been accomplished, try to re-enable the DBuffer Decals and see if it will open, when it does open it is expected that the shaders will recompile.

Thank You

Eric Ketchum

Hey Eric,
Thanks for the reply I appreciate it.
I did try what you said, went to Nvidia Control Panel and I set the UE4Editor to use High Performance. As for to make sure there are no settings that force all programs to use the integrated graphics, I don’t know what really means and where I should do that. But if I got it right, my laptop is always on high performance because it’s always on full power, I never remove the cable from power socket. Sorry if I didn’t understand right.
So, I tried and again the same bug appears, I can’t use the DBuffer Decals.

Hi -

Ok, let’s try updating your Nvidia drivers as well you should be able to get 361.75+, you are currently on 355.98.

Eric Ketchum

I did that last night, updated to 361.91, and can’t make DBuffer work :frowning:

Ok, I tried again because I couldn’t help it and tried the DBuffer. Now I noticed something else and I don’t know if it means something. So, after I checked DBuffer and restarted Unreal Editor, it got stuck to initializing 45% as usual and closed it using Task Manager. However I clicked on the little UP arrow on the bottom right at the task bar that reveals the hidden icons and I saw the Nvidia icon that shows how many programs are working with Nvidia. I hovered over it with mouse, the notification bubble said it’s 2. So got curious and wanted to see what are the 2 programs and then this Error notification of windows appeared:
“An app default was reset - An app caused a problem with the default app setting for .html files, so it was reset to Microsoft Edge.” After that I clicked again on that Nvidia activated programs and there are 2 icons:
Unreal launcher and Unreal ICEFSubProcess.exe.
Does this mean anything?

Hi Belkim -

If you are using the Launcher version of the engine can you try to verify the engine and then try to open your project again, also please look in the following directories and attach the latest logs from those directories here.

C:\Users[UserName]\MyDocuments\UnrealProjects[ProjectName]\Saved\Logs
&
C:\Users[UserName]\AppData\Local\UnrealEngine[Engine Version #]\Saved\Logs\

Thank You -

Eric Ketchum

Hi Eric,
First of all, I want to thank you for taking your time to help me with this.
I have attached the logs and named them according to where I found the log folders. I really hope they will salve the mystery with my laptop. Not so sure what you mean with verifying the engine and then trying to open the project. I click on the Icon on start and then after I click the Library and click the Launch button that’s near the Unreal logo. After it opens the option to chose the project I chose the one I want and then click Open or sometimes just double click on the thumbnail of the project.

At the AppData > Local > UnrealEngine there is also a 4.12 folder, :slight_smile: it’s not big but just saying.
As for now I’m connecting the texture with the Emissive Color (and multiplying it) and it’s doing the job at the moment as decal.

Hi Belkim -

I am digging into the logs now, but by verify I mean going to the library of the Launcher and in the drop down menu for the engine version there is an option to verify:

Thank You -

Eric Ketchum

HI Eric-
I just verified the engine and it took a while, after that I tried the DBuffer and again the problem persists. Maybe the Nvidia version that I have is the problem.

Hi Bekim -

No your Nvidia Driver should be correct, I am running the same driver though on a different card. Lets try removing all the Derived Data Cache and compiled files and see if that will allow you to get DBuffer Decals working.

  1. Make sure all versions of the engine and the Epic Games Launcher are fully closed
  2. Go to the following Location (you will need to be able to see Hidden Files and Folders): C:\Users[Your CPU User Name]\AppData\Local\UnrealEngine\
  3. Delete all the Folders in this directory, should at least be a 4.10 and Common Sub-directory
  4. In the Project location, delete the Intermediate, Saved and if there is a directory Derived Data Cache (though this one may not exist).
  5. Open your project, it will take a bit as all items must be recompiles again.
  6. Go into your Project Settings
  7. Under Rendering, Enable DBuffer Decals, Set Early Z-Pass to Opaque and masked meshes, and Enable Moveables in early Z-pass
  8. Restart your project

Let me know the outcome -

Eric Ketchum

Hi Eric,

I tried every step you mentioned, but still doesn’t work, as soon as I turn on the DBuffer or the other 2, it gets stuck on 45% while initializing. I guess it’s just my pc and its own drivers or something, or maybe I did something while experimenting. Not sure anymore.

Hi -

The last thing I can think of to try is upgrading the Intel Integrated graphics process on your Acer from the following website:

We have some conflicts listed on our Software Conflict page where certain Laptop Manufacturers will not allow you to upgrade to the linked version in which case you will have to “downgrade” driver versions and then upgrade to the linked version.

You will need to use the linked website above and not go through any Acer application as they may tell you that the driver is already up to date when in fact it is only up to date with what the manufacturer supports.

Eric Ketchum

I went to that site and since my OS is Windows 10, i downloaded the driver package from this site:

and it failed. I even downloaded the intel utility tool for upgrading and it won’t let me because it’s the manufacturer custom driver. Went to Acer site:
http://www.acer.com/ac/en/GB/content/drivers for my laptop "Aspire VN7-571g and saw the driver:
AMT Intel Intel AMT Driver 11.0.0.1155 60.7 MB 2015/09/03
and the link for download but not sure what is that AMT and got scared I’ll mess up my pc. I don’t know which driver to download to ‘downgrade’ the intel driver.
Intel® Graphics Driver for Windows® 10 [15.40][4th Gen]
Tried this one that seems to be older version but failed too. I’m not good at this and don’t know at what link what I should do.

Hi Bekim -

We haven’t forgotten you, I am diggin in today to see if I can get explicit instructions on how to upgrade that Driver for you.

Eric Ketchum

Hi Eric,

Thanks so much. I soooo appreciate this. You guys rock!

At the moment I’m just using the ‘emissive’ color inside the Decals, it’s working for this project, since I’m still at the learning point. But I would needed when I want to put non-glowing decals.

Again, thanks for helping, I really appreciate this.

Let’s Try this:

  1. Open the Nvidia Control Panel
  2. Go to Manage 3d Settings
  3. Under the Global Settings Tab, Look for Preferred Graphics Processor
  4. Select High Performance NVIDIA Processor
  5. Reboot Machine
  6. Try to see if you still get the crash

Please remember that since we are using the higher performance card now for all functionality on your laptop, the battery life will be decreased so you may want to have it plugged in.

If that doesn’t work try this:

Download the Intel Integrated Graphics Driver. Go to System, Device Manager in control panel. Right click the driver name, on the driver tab try the roll back option, if greyed out click update, select file from disk or browse computer or point it to your driver folder and press open. should give you a list of drivers (if any)

One additional note that one of our support engineers pointed out as well, is the laptop native to Windows 10 or did you upgrade to Windows 10 from 8.1? Since laptop manufacturers are particularly slow to upgrade drivers for a new OS, there have been reported issues with GPU and GPU Switching issues from upgrading laptops, due to driver incompatibility between Windows 10 and the laptop.

Eric Ketchum

Hi Eric,
I did try that first option long time ago and it doesn’t work.
The second option, I checked in device manager but instead of rolling back it gives me an option to ‘uninstall drivers’ and now I’m kinda scared to do that, because I don’t know what to expect after. I’ll try next week at work with my colleagues if anyone knows something. Maybe I’m checking on wrong place.
As for the question, I bought the laptop with Windows 8.1 installed in it, then after a week it asked me if i want to switch to Windows 10, so maybe that’s one of the problems.
Sorry for replying late, just got so busy with regression tests that i had no time for anything.