Cut of cloud shadows

Hi everybody

I tried to set up an cloud particle system and followed these instructions:

But the shadows of the clouds are cut of. When i lower the particle system the cut appears further to the left, when i pull it up it occures farther to the right until it completely disappears.

It looks like there is some kind of volume wherein shadowing occures but not beyond.
I thought it might be a problem of the Particle system bounding box but it is big enough.

Does anyone have an idea what is causing this and how i could fix/bypass this issue?

Hi Malark -

That hard line is most definitely bounds related. Go into your Particle System’s Details by clicking teh black area to the right of your emitter module stacks. In the details panel, Find Bounds and roll out the fixed Relative Bounding Box. Set a very high Min and Max Amount here. I recommend (-10000,-10000,-10000) for min and (10000,10000,10000) for max.

Let me know if this does not fix your issue -

Thank You

Eric Ketchum

Hi Eric,

thanks a lot for the reply.
I figured that the cuts appear exactly where the “shadow frustum” ends which is directly related to the bounding box (?).
In these pictures you can see it clearly:

The turquoise volume is the shadow frustum. I thinks It is aligned along the directional light direction. And that is why it is rotated to the left (from view)? I don’t know how it is calculated exactly.


I had the bounding box adjusted so it fits the whole particle system as seen here:
(-5000,0,-30000) min (70000,70000,6000) max


The cuts (green marking):


Still when i change the bounding box to something huge the shadow frustum doesn’t get bigger as i expected.
New bounding min(-80000,-80000,-80000), max(80000,80000,80000):


And the resulting shadow frustum which is way up to the left and not really bigger than before.
Furthermore it’s so much off that there are no shadows anymore. Green marking is the whole scene:


Is this a bug? Or am i just missing some important settings?
Maybe a particle system is not the right way to achieve large scale clouds?

Hmm, First check to make sure that you are running with Engine Scalability at EPIC level and that your Screen Resolution is set to 100%. If this doesn’t fix the issue for you, take a look at the sample project I have attached below and let me know what additional variables make your project different from this test project. Feel free to update and make changes to the attached project as well and if a reproduction is made, please reupload the project here.

Thank You

Eric Ketchum