Download

Cull Distance Volume for Skeletal Meshes

Hey,
I can’t make Cull Distance Volume work for Skeletal Meshes. Static meshes placed nearby all disappear, but skeletal meshes don’t. I displayed their bounds and it all looks good.
Manually setting “Desired Max Draw Distance” in Details/Rendering/LOD also works. And checkbox “Allow Cull Distance Volume” is set to true. Existence of that checkbox suggests that Cull Volume should also work for skeletal meshes. But does it?

Edit: Ok, I just found the answer in ACullDistanceVolume::CanBeAffectedByVolumes(). Dynamic actors are ignored by Distance Cull Volume and my meshes had Movable mobility.