Download

CTRL-L not working correctly (no more rotation of the sun)

I have stumbled upon this when I followed a tutorial about creating planets, placing lights, sun, atmosphere - a very beginner tutorial.

In this tutorial it is said that the shortcut CTRL-L will let you move the sun at will. It works, but only for a bit, then just stops working for good - until I completely reload a project.
There seems to be some movement going on in the sun move directional dial and I also saw some x, z numbers moving in the coordinates at the right.
This happens within all my projects as far as I checked.
[video]https://streamable.com/t3btjf[/video]

Is it possible to rotate the sun for more than 5 seconds? If so what could be my problem…

Edit: Yes, I was able to move the sun slowly for 1 minute! But the moment I went a bit faster with the directions (moving the sun in literally everywhere), the sun freezes in place once more.
[video]https://streamable.com/lffdcw[/video]

MySpecs: UE4 4.25, Win10 64bit, Ryzen 5 1600Hz 6core 3.50Ghz, 16GB, 34" Acer, 1TB SSD Force MP510 NVM Express

Could you please check if it locks once has a certain rotation? In other words, you need to reset its rotation, to be able to play with the CTRL L rotation again?

I think the lock occurs when the sun is underneath the ground, pointing upwards.

There seems to be a pattern indeed. Now I looked more carefully at the sun-icon while rotating - and you had a good hunch there - the sun-arrow shows upwards when the sun suddenly stops.
Exactly like it did in the last video I posted here. I replicated the situation several times and it stays consistent. I need to press CTRL-Z to go back to be able to rotate once more (and then go back again, etc.).

Edit: In another project I cannot even start rotating the sun because it already got stuck and stepping back with CTRL-Z cannot be used because the rotation action may have been overwritten from memory by other actions I did after getting stuck. I somehow need to get rid of that North-Lock.

How should I proceed?

The way I see it, it seems to have to do with the angle. So from experience, I try to avoid landing in this exact angle, “locking” the light actor.
Now, one could say its a buggy behaviour, there should be a way to get out of it with CTRL L

Instead, if this ever happens to me, I simply go reset the rotation values or rotate it out of its state, and then I can use CTRL L again.

Let me know if this works for you, good for me to get a confirmation to be sure myself :slight_smile:

This is gimbal lock

Yeah, it worked out. I released the “Y-axis: 90°”-lock by manually changing the value from its locked 90 value to any other. So as long as I do not strike 90° again, I am golden. Good enaugh workaround to me.

Having same problem, but I see no rotations of anykind interfering, anyone have a screenie of this issue ?

Is CTRL L not working for you at all?
To make it work, you need to activate inside Directional Light > Light > Atmosthere / Fog Sun Light
Only then, CTRL L will work.

There is no such ‘fog sun light’ option. I filtered the word ‘fog’, and got zero hits under directional light. Using the newer Sun and Sky

It’s called “atmosphere sun light” now, in the atmosphere and cloud dropdown of the directional light (in the components of the sun sky bp).

On another note, I’ve also had this problem with my main project since updating it to 4.26, ctrl+L gizmo shows up, and can be moved in a limited way but always returns to its initial location, it just wobbles around. Also in prior versions, it would gimbal lock at full up or down and can be solved by manually rotating the light.
The system works fine in new projects.
My project has been going since 4.4 days, so I think something in the configs might be messing it up.

4.25 https://drive.google.com/file/d/1rPCOvrnQYCv1vu7LjLXYlvDWHlvXH7Pf/view?usp=sharing
4.26 https://drive.google.com/file/d/1JiAaWUkbbvLsNV8xmdWrt7c-Bq-wkx1p/view?usp=sharing

2 Likes

I guess, they somehow have linked the sun to a clock and calendar, and unless you change that time and day, the sun will always return to the state and position, the set date and time would dictate.
A new gizmo seems not to have such time and calendar installed, or not activated by default, so you can move the sun freely around.

I was referring to the plain Directional Light setting.

When you use the Sun and Sky in Unreal Engine 4.25, CTRL L should work. But you wont be changing the blueprint’s (Sun and Sky is a blueprint) you wont be changing the values under Location or Date or Time. As soon as you change something under those categories, it will jump back to the value set in the blueprint actor.

In Unreal 4.26 this has been fixed and hence you cant use CTRL L anymore.

In a perfect world, CTRL would update the values in the blueprint :slight_smile: Then we’d have the best of two worlds - changing values to match true world location, or CTRL for a freehand manipuolation of the sun.

Ty for clarification and that this is meant to work this way in 4.26 ;))
Have a wonderful day!

On top of that: the problem with the directional light being stuck with CTRL+L should be gone in 4.26.

Guys I had a similar problem where my CTRL + L for the Sun stopped working. I fixed my problem because I had made a change to the Atmosphere sun light option in the directional light attributes. Default is 0 which is where you can use the ctrl+L, but toggling it to 1 says you can have 2 sun instances…which disables the ctrl+L shortcut for your sun.

2 Likes

Same here. The arrow does not rotate at all. This was after Early access 1 to Early access 2

i solved it by pressing ctrl + L when im ready to rotate, i release the L still holding ctrl then move my mouse