Crash on attempted connect

Good day,

I have come across a problem with accessing a multiplayer game. I can create the game just fine, but when I try to join it crashes the PIE. I tested it with the MultiplayerShooter example and it does the same thing there.

It gives the following warnings in the console log:

LogNet:Warning: Travel Failure: [LoadMapFailure]: Failed to load package '/Game/Maps/UEDPIE_2_Level_01'
LogNet:Warning: Travel Failure: [LoadMapFailure]: Failed to load package '/Game/Maps/UEDPIE_2_Level_01'
LogNet:Warning: TravelFailure: LoadMapFailure, Reason for Failure: 'Failed to load package '/Game/Maps/UEDPIE_2_Level_01''. Shutting down PIE.
PIE:Warning: Warning TravelFailure: LoadMapFailure, Reason for Failure: 'Failed to load package '/Game/Maps/UEDPIE_2_Level_01''. Shutting down PIE.

This happens shortly after pressing the button to join the game.

Is there any way to get around this? Is it a known issue?

I have recreated my project from scratch and it gives the same issue. I have added the dependencies in my DefaultEngine.ini as well as *.Build.cs source. I am able to create the game, just not join it.

This does not happen in a packaged build. This makes it take way longer to debug network only issues that involve the map changing.

Hi iRperson,

Thank you for reporting this to us. I have a few questions to gather some information so I can try to pinpoint the cause of this crash.

  1. When you crash, does the crash reporter appear? If so, can you please provide me with the callstack from that and also the crash log file itself? This can be found in the project’s folder under Saved > Logs.
  2. I see that you selected 4.8 for the product version but are you running any of the hotfix versions? If so, which one?
  3. What OS are you using?
  4. If you have the time and bandwidth, can you try to see if this issue still occurs in the 4.9 Preview version of the editor? Please avoid converting any projects to Preview without making a copy first as Preview builds aren’t fully tested.

Hello there ,

  1. There is no crash reporter that shows up. To clarify as well, only the PIE crashes, not the entire editor. The only warning I get is the one listed above in the output log.
  2. I am using 4.8.3
  3. Windows 10
  4. I just left town for the long weekend, will attempt this on in they my return.

Thank you for the information. 4.8 and it’s hotfixes currently do not have any native support for Windows 10 at the moment so I would be interested to see if this issue persists in 4.9. Take your time and I’ll be waiting to hear the results.

I downloaded v4.9P3. It no longer crashes the PIE, but it does destroy the Main menu object, preventing me from Joining a game. Again, this does not happen with 2 instances of the packaged project running on the same PC.

I also am now receiving 60 Map Check warnings for “Externally Referenced”, such as below:
Warning Polys_1001 Polys /Game/ThirdPerson/Maps/First.First:PersistentLevel.PillarPoleWest.Model_10.Polys_1001 : Externally referenced

I also want to note that the Brush meshes are now able to align again. They were not doing so in v4.8.3

I’m glad to see that the crash has stopped but lets look into this new issue. To clarify, is this in your custom project or does this also happen with the MultiplayerShooter example (I believe this is Shooter Game?) that you were using to test this against earlier?

As for the warnings, I’m assuming this project was upgraded to 4.9 Preview 3. If this is the case, it’s most likely due to the project trying to reference the assets from 4.8’s content. The best way to fix this would be to replace the references w/ the 4.9 version of the same asset.

It does give the same error on the MultiplayerShooter example. I have tried going into these functions but it only lets me get so far in the blueprints.


Error Accessed None ‘CallFunc_K2_GetPawn_ReturnValue’ from node DestroyActor in graph ‘EventGraph’ in blueprint MyGameMode

Error Accessed None ‘Widget’ from node Remove from Parent in graph ‘Hide Widget’ in blueprint MyGameInstance

It seems like this may be something to do with deprecated nodes or something of the sort. Would it be possible for you to send me a copy of the project so that I can try to find the issue? If you would like to send it in a private manner, you can send a link to me in a private message on our forums. My forum username is .

Seeing as I get the same issue on either project, here is a OneDrive link to the MP Shooter project. Will also help me learn by implementing the changes (if any) into my own project.

Let me know if I can be of any additional help!

Hello iRperson,

I apologize for the time since my last response. It seems that the way the networking for Multiplayer Shootout is set up, it isn’t designed to work in PIE. It does however work in Standalone, even without packaging.

I’ll be looking into a way this could be changed to work in PIE but I would suggest doing multiple instances of standalone by right-clicking the .uproject file and selecting ‘Launch Game’ in the meantime.

No problem, I thought it was designed in a universal way. It is just the menu transitions, so it is not a big deal.

Thank-you very much for having a look at it for me though! I hope you have a fantastic weekend!