Cooking levels

Hello, I have 3 levels in my project. But when i package it, only default map (Game Default Map from Project Settings->Maps & Modes) is cooked. How can i cook all my levels?

I have the same problem. I’ve created a blanked project. Add two levels. Packaged. Only default level + default server level are cooked. All other were ignored. Doesn’t matter where have they been: in “Maps” folder or not.
If I’ll use “Startup content” - everything will be fine.

Only through Maps folder and FrontEnd I was able to package the project, but not through Editor menu.

Packaging will build All Maps.
However you can specify what set of maps is considered “All Maps” very handy to not include test maps or old maps.

Check in DefaultEditor.ini you might have something like this:


Which could be causing the undesirable set of maps to be built.

Im VERY new to this…having the same issue… where is the .ini found?

Configuration Files

This link will help you out as configuration files are in many places they override each other it’s speaking about the engine.ini but most principles apply. Engine level settings, project level, local level.

Most likely your looking for:




If you remove that whole section it will build all of the maps it can find in content.

We often set it manually because by default we know building a subset of maps is faster and all that required. Really it’s a time saver since we have many many maps quite a few of while are no longer maintained. On a smaller project removing that section certainly may be desireable.

Thank you for answer, Chris.

But why I should set All Maps manually? Maybe my build process trying to found maps in somewhere else but Maps folder ?

Maybe because of my blank project without starter content, but it won’t build all maps by default.

If [AllMaps] in the .ini files is empty it will build all the maps in your projects content menu. A blank project would not have any maps, are you trying to build maps stored outside the content directory?

You can add content extra paths in the project settings, I’d avoid this complexity if you can.

In project setting under packaging there is a tab called list of maps to build, there you can set which maps you want to be built in the final package, I just figured it out myself.

Note that I’m using 4.10 I have no idea if it works in earlier versions.

1 Like

Thanks. This worked.