Content Examples Lighting.umap seems buggy in 4.9

When I open the level I notice flickering moire patterns and lines everywhere (view the image below fullscreen).

I tried disabling the directional light and some other local lights as well as rebuilding lighting and still get the same results.

I’m very curious what the cause is as I have several projects I would like to upgrade and am worried I might run into the same issue.

It looks like SSR/TemporalAA issue rather than lighting. Change those settings in post process to see if they affect the looks.

Good idea to test but I disabled AA completely but it actually makes it worse. Which I guess is a good thing for trying to track down the cause. Funny thing is it only seems to happen on this map that I’ve seen so far.

I’m guessing it’s some sort of self shadowing bias thing maybe? But where would you set something like that globally for a single map?

Opps I missed your mention of SSR. The issue is definitely something in the global post process volume. I disabled it and the effect went away.

I dont think there is a global parameter for that. But that reminds me of something…is Use Ambient Occlusion enabled in World Settings > Lightmass Settings? If it is could you disable it and try rebuilding the lights? And before that could you enable Force No Precomputed Lighting in the same section and see how the level looks with dynamic lighting alone?

Ok, ignore my post above then. :slight_smile: I might have had some ideas if this occured in other levels as well but you say it is happening only in this level so… : \ Try deleting the pp volume and creating a new one. It may have been corrupt somehow.

Turns out the Ambient Occlusion Bias in the global post process is overridden to 0.0. Defaulting it back to 3.0 seems to solve the issue, or i guess you could set it down to something like 0.75. I wouldn’t have found it or at least not nearly as quickly if you hadn’t suggested SSR/AA though, so thanks! :slight_smile:

It’s still probably considered a bug that should be changed in the map.

Also in the same map I found a minor mislabeling. The words “Source Radius” in exhibit 5.4 should read “Min Roughness”. Looks like they copy-pasted from 5.2 but forgot to change that label.

Perhaps they can fix both of these together.

Cool, glad you figured it out! Since the post is in Bug Reports section already Epic should be able to see and fix it soon.

Hi Tmek,

I’ve fixed the AO Bias issue and fixed the text in the demo for 5.4 to now read as Min Roughness.

Thank you for pointing this out.