Compile failed

I downloaded UE5.2 to a clean laptop, I’m trying to create a project in C++, downloaded Visual studio, which is offered directly in the launcher with all plugins, the following error is displayed:

Running C:/Program Files/Epic Games/UE_5.2/Engine/Build/BatchFiles/Build.bat Development Win64 -Project=“C:/Users/juust/OneDrive/Документы/Unreal Projects/MyProject/MyProject.uproject” -TargetType=Editor -Progress -NoEngineChanges -NoHotReloadFromIDE
Using bundled DotNet SDK version: 6.0.302
Running UnrealBuildTool: dotnet “…..\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.dll” Development Win64 -Project=“C:/Users/juust/OneDrive/???㬥??/Unreal Projects/MyProject/MyProject.uproject” -TargetType=Editor -Progress -NoEngineChanges -NoHotReloadFromIDE
Log file: C:\Users\juust\AppData\Local\UnrealBuildTool\Log.txt
Creating makefile for MyProjectEditor (no existing makefile)
@progress push 5%
Parsing headers for MyProjectEditor
Running Internal UnrealHeaderTool “C:\Users\juust\OneDrive???㬥??\Unreal Projects\MyProject\MyProject.uproject” “C:\Users\juust\OneDrive???㬥??\Unreal Projects\MyProject\Intermediate\Build\Win64\MyProjectEditor\Development\MyProjectEditor.uhtmanifest” -WarningsAsErrors -installed
Total of 4 written
Reflection code generated for MyProjectEditor in 1.0638166 seconds
@progress pop
Building MyProjectEditor…
Using Visual Studio 2022 14.34.31946 toolchain (C:\Program Files\Microsoft Visual Studio\2022\Community\VC\Tools\MSVC\14.34.31933) and Windows 10.0.18362.0 SDK (C:\Program Files (x86)\Windows Kits\10).
[Upgrade] Using backward-compatible include order. The latest version of UE has changed the order of includes, which may require code changes. The current setting is:
[Upgrade] IncludeOrderVersion = EngineIncludeOrderVersion.Unreal5_1
[Upgrade] Suppress this message by setting ‘IncludeOrderVersion = EngineIncludeOrderVersion.Unreal5_2;’ in MyProjectEditor.Target.cs.
[Upgrade] Alternatively you can set this to ‘EngineIncludeOrderVersion.Latest’ to always use the latest include order. This will potentially cause compile errors when integrating new versions of the engine.
Determining max actions to execute in parallel (8 physical cores, 16 logical cores)
Executing up to 8 processes, one per physical core
Requested 1.5 GB free memory per action, 5.14 GB available: limiting max parallel actions to 3
Building 9 actions with 3 processes…
[1/9] Resource Default.rc2
[2/9] Link [x64] UnrealEditor-MyProject.dll cancelled
[3/9] Compile [x64] SharedPCH.Engine.ShadowErrors.InclOrderUnreal5_1.cpp
c1xx: fatal error C1083: ?? 㤠???䠩? ?஬??? ??? ??? C:\Users\juust\OneDrive?"???'?<\Unreal Projects\MyProject\Intermediate\Build\Win64\x64\MyProjectEditor\Development\Engine\SharedPCH.Engine.ShadowErrors.InclOrderUnreal5_1.h.pch: No such file or directory,
[4/9] Compile [x64] MyProjectGameModeBase.cpp cancelled
[5/9] Compile [x64] MyProject.cpp cancelled
[6/9] Compile [x64] MyProject.init.gen.cpp cancelled
[7/9] Compile [x64] MyProjectGameModeBase.gen.cpp cancelled
[8/9] Link [x64] UnrealEditor-MyProject.lib cancelled
[9/9] WriteMetadata cancelled

Greetings @JuustPush

Welcome to the Unreal Engine Forums! There were some users who experienced this issue prior and provided some solutions on an older post. Here is a link to that post. Check out the solution provided there and let me know if that resolves the error for you. I hope that this is helpful!

Greetings @FrostyJas
I installed the universal SDK, but it still doesn’t help

My problem solved. The error was that there was a folder containing Cyrillic in the project path

Excellent! I’m glad that you got that resolved. Have a great day!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.