Fatal error C1083

I’ve tried to generate a new UE4 Project (C++/Third Person) but I always get the following error

The project could not be compiled. Would you like to open it in Visual Studio?

Running C:/Program Files/Epic Games/UE_4.17/Engine/Binaries/DotNET/UnrealBuildTool.exe AnotherWorld Development Win64 -project="C:/Users/Paul/Documents/Unreal Projects/AnotherWorld/AnotherWorld.uproject" -editorrecompile -progress -NoHotReloadFromIDE
Creating makefile for AnotherWorld (no existing makefile)
Performing full C++ include scan (no include cache file)
@progress push 5%
Parsing headers for AnotherWorldEditor
Running UnrealHeaderTool "C:\Users\Paul\Documents\Unreal  Projects\AnotherWorld\AnotherWorld.uproject" "C:\Users\Paul\Documents\Unreal Projects\AnotherWorld\Intermediate\Build\Win64\AnotherWorldEditor\Development\AnotherWorldEditor.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed
Reflection code generated for AnotherWorldEditor in 18,9575823 seconds
@progress pop
Performing 11 actions (2 in parallel)
[2/11] Resource ModuleVersionResource.rc.inl
[3/11] Resource PCLaunch.rc
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.11.25503\INCLUDE\cstddef(5): fatal error C1083: file (Include) could not be opened: "stddef.h": No such file or directory
ERROR: UBT ERROR: Failed to produce item: C:\Users\Paul\Documents\Unreal  Projects\AnotherWorld\Binaries\Win64\UE4Editor-AnotherWorld.dll
Total build time: 42,13 seconds (Local executor: 0,00 seconds)

How can I fix this error?

I’m using Windows 7 Home Premium 64bit, Visual Studio Community 2017 (15.3.5) and Unreal Engine 4.17.1.
I’ve installed the Visual Studio “Game Development with C++” workload.

I know this is an old question, but I thought I’d toss in my answer for anyone who stumbles across it.

You might be experiencing the same issue I had, that is, I was missing the UCRT SDK. When you are Modifying your VS install from the Visual Studio Installer, be sure you install the Windows Universal CRT SDK along with which ever version of Windows SDK you are using. In my case, I only had Windows 8.1 SDK component and was receiving the same error.

Once you have the Windows Universal CRT SDK installed, try making a new project with the same settings. Your old projects will not build for what I assume is a problem with the solution properties not including the new ucrt include path.