Download

Colour problem with translusent unlit material

Hi, I’m trying to create an unlit translucent material. Even though the material is marked as ‘unlit’ there is a difference between it being ‘lit’ and ‘unlit’ in editor and game:


The material looks normal when ‘unlit’ (top image) but looks overly bright when ‘lit’

This also applies when rendered in game with no light sources.

Here is a comparison of my game running in Unreal (left) and OpenGL (right)


You can see what is supposed to be Purple comes out as Pink in unreal. I’ve checked the RGB values in Photoshop and the right image in bang on where as Unreal on the left is altering them some where.

I’ve tried messing with all sorts of settings but I just can’t get a Translucent material to have the desired colour when rendered in the editor or game.

Any ideas?

For reference, here is my Material, it’s pretty simple.

The material graph is posted 3x.

Try either reducing the Alpha value or removing it from the material graph. I think with emissive, unlit (the material editor setting, not the viewport mode), there’s a built-in alpha present that’s separate from any alpha node set in the created graph. That’d brighten the final result.

There’s also a setting for emissives that enables / disables its ability to project light into the scene, and to receive light from the scene. And why are you using three separate nodes to get R, G, and B values, and appending them? A 3-vector parameterized would work the same, if not better, I think.

Hi, if you set your view to “unlit”, that means you’re only viewing the color, no post processing, no emissive.

If you set the view to “lit” then you also have post processing and since you’re using emissive color in your material that will also look different.
[HR][/HR]
Since you apparently want to use this for UMG, why not use a widget and set then set the material domain to “User Interface”? Then you will always have the same color.

Yes, I assume post pressing is being applied somewhere but I’m not sure where. Everything is turned off and I have no lights in the world. Surely a material marked as ‘Unlit’ should receive no lighting?

Re UI: I’m also using this material, along with an additive version all over the game. Currently all colours are slightly wrong due to this issue.

I’ve had some success in compensating for the extra lighting, but it would be nice just to switch it off.

I’ve even tried a custom node with my own HLSL code in, but this has to go into the Emissive Colour and so the problem persists.

Is there anyway to have a look at the emissive shader code? I’ve had a quick search but couldn’t find anything.

For anyone looking for a solution, I did find one. I added a post-processing volume to my camera and set exposure to manual, compensation 10. This seems to override whatever exposure was being applied before and resulted in something that looked way better.
Not perfect, but a lot better.