Changing AA Type via Console Command

Alright so while I was setting up my menu screen and moved onto the options menu I came across the scalability referemce (Scalability Reference for Unreal Engine | Unreal Engine 5.1 Documentation) It talks about the Anti-Aliasing but what if I want to switch between FXAA and Temporal AA. I know that I can go into the global post processing volume or whatever and change it in there, but what about in mid game using console commands?

The wiki is also very confusing in this part where “For FXAA, the effect of values 2, 4, and 6” so I thought, oh so if I use 2,4,6 in my console commands it would be FXAA and 1,3,5 would be temporal. But later down the wiki “For Temporal AA, there is a trade off between fill speed of the effect and quality, the higher the value you use. r.PostProcessAAQuality 2 with…” It is also using 2, which I thought was for FXAA.

But apparently we can also use sg.AntiAliasingQuality 0 which goes from 0-3, Low Medium, High and Epic. But what type of AntiAliasing is that and how can I change it. What is the difference between sg and r?

EDIT: Also not sure if this is meant to be here in rendering. Should it be in blueprints or everything else?

Hello Soulweaver,

The documentation for FXAA where the pictures show the differences with the numbers of 0 through 6 are simply showing the quality differences of the Anti-Aliasing method. Where 0 is completely turned off and 6 is the highest setting. You need to set which type of Anti-Aliasing method you would like to use within your Post Processing Volume first, and then use the console commands to vary the quality.

“Adjusting the Anti-Aliasing quality level using the r.PostProcessAAQuality console command will adjust the quality of which ever Anti-Aliasing method you are using (FXAA or Temporal AA).”

With that being said, if you would like to change the type of Anti-Aliasing method you are using at runtime, you can have multiple post process volumes in your level with their bounding boxes overlapping. You could then walk out of one post process volume with it set to Temporal AA, and walk into a volume with FXAA. You directed your question to the right section by the way.

If you are still a bit confused or need additional assistance, let me know.




I use unreal for architectual presentations.
Even if I set up the ProstProcessVolume to use Temporal AA and a “good” quality ScreenSpace Reflection values
I still have to type r.ssr temporal 1 to the console when starting the *.exe file to get rid of the noise :S
How can I set up my scene or package to get rid of this issue?
Im using version 4.8 now.


Hello GezaKadas,

It is probably because you are using invalid values for those fields.

For the Screen Space Reflection in regards to the Quality setting

0=Lowest Quality while 100=Maximum Quality (50 is the default to provide better performance).

Also, you are scaling the screen percentage by 250% which renders the scene at a lower resolution and then scales it up. The value represents a percentage of the overall resolution of the scene.

Screen Percentage

‘r.SSR Temporal’ is dealing with screen space reflections and the effects of temporal AA on this feature. Be sure you engines scalability settings are set to Epic in order to get the highest visual quality when packaging your game.

Scalability Reference

Use the documentation above as a reference for how to modify your post processing quality. Let me know if you have further questions.

Thank you,

Thank you for your help Andrew :slight_smile:
The settings are on epic I have checked it.
I think some of my problems are coming from the *.ini files.
How can I bring my ini files (ini stack) settings to the packed file?

Thank you !

No problem. I would definitely look into the Packaging and Deployment documentation to get a solid understanding of how to correctly package your project.

Packaging Projects


Here my friend:

Works in 4.13.1
0 = none
1 = FXAA
2 = TemporalAA