Certain console commands not working

I have no idea if this is a bug or a mistake on my part, but console commands for Light Propagation Volumes and Distance Field Global Illumination don’t work for me. I was excited to recently learn that there are console commands to tweak the quality of LPVs, namely r.LPV.RSMResolution and r.LPV.NumPropagationSteps. Trying them out however did nothing for me.

The exact command I used was, for example: “r.LPV.RSMResolution 1024” (without quotation marks). I also tried all other variations I could think of, but from what I understand this one should be correct.

Usually I would attribute this to to a problem with the LPV or with my project, but it doesn’t work in a clean new project either, nor did the console commands for DFGI from this thread. Other commands (stat unit, slowmo, HighResShot, et cetera) all execute without problems.

If anyone has any ideas what I could be doing wrong or what could be going wrong, please let me know!

Try add this console variables to global INI file


or create this file in project folder

Ah, I should’ve mentioned that: I already tried adding the command to the ConsoleVariables.ini but that had no effect either. I used an “equal” sign before the value (i.e. “r.LPV.RSMResolution=0”), but I also tried several other variations with no success.

Unfortunately I don’t have access to UE4 right now, but I can upload a sample project and the ConsoleVariables.ini I’m using later today. Maybe that will shed some light into what’s going on…

I tried out some more stuff and noticed that the commands are working in 4.9. They don’t do anything in 4.8 and 4.7, so I’ll just assume that there’s either a bug in those versions, or that they have only been added recently in the latest version of the engine. Which, ironically, I can’t use (yet) because of other LPV bugs. :smiley: