Cascade shadowmaps resolution

i have scene with stationary directional light baked light is awesome but my cascade shadows very low resolution and they only got crisp when i get too close like 10cm from camera. i played with every cascade settings at directional light but cant find a solution. is there a way to make cascade shadows alway highest resolution? i really dont care performance issues since scene is for archviz.

Consider adding a screenshot to the post, so that we can know how bad does it look for you.

Hi Alperenozgur,

It sounds like your distribution exponent is too high on your cascaded shadow maps. Try a lower value to see if that solves the issue. If it doesn’t please provide a screenshot of your directional light settings as well as the shadows that have a low resolution.

Thanks,

Ed Burgess