"Can't find file" for hidden/unkown references

Hello fellow devs,

First of all: I am aware of the similar topics. None of them helped, unfortunately.

I am struggling with this for hours, now. I hope you can help me with this strange situation. I am also unable to reproduce this in a clean project by intent. Re-creating the following in a clean project is an option I don’t actually want to think of.


Similar to many other people, my problem is that I have a Blueprint “PartAsset_SK_Hat” referenced in several Blueprints and one structure. Now, I renamed it to “BP_PartAsset_SK_Hat” for marketplace convention. If I do so and fix up its Redirector, the warning below appears after restart of the engine.

LogLinker: Warning: Can't find file '/Game/Blueprints/PartAsset_SK_Hat'
LogLinker: Warning: Can't find file '/Game/Blueprints/PartAsset_SK_Hat'
LogUObjectGlobals: Warning: Failed to find object 'Object /Game/Blueprints/PartAsset_SK_Hat.PartAsset_SK_Hat_C'

That’s a usual problem for wrong redirectors… I know. But I thought I fixed them properly. Please, read on:

I reverted the renaming process in Perforce and tried copying “PartAsset_SK_Hat” to “BP_PartAsset_SK_Hat” and even created a brand-new “BP_PartAsset_SK_Hat” from scratch. Then assigned the copied/new “BP_PartAsset_SK_Hat” manually to every single reference I was using: variables, function parameters, cast nodes etc. (literally every reference; I was desperate xD).

Now the weirdest part so far: After all done I tried to delete the old “PartAsset_SK_Hat” and even then the “Delete Assets” window showed me 3 more Blueprints which had references to the old Blueprint about to be deleted, what could not be the case. And in NONE of them I could find an actual reference at the first glance. But more of accidentally I found, that one of the Blueprints had a function return parameter of type of the “PartAsset_SK_Hat class” created several days ago and plugged to a “select class” node. I could not really think of plugged on pins still can have references the engine is not able to be aware of, when fixing up redirectors.

Well, resolved 1/3. But didn’t find any more clues in the other 2 Blueprints so far. With my new knowledge I unplugged any pin in question and re-compiled the Blueprints and re-started the engine the many times, but no luck so far.


Do you know any other ways to find badly broken references, UE4 does not even seem to be aware of, properly?

I mean, how can “Fix up Redirectors” does not fix up truly ALL references and leave some blind ends open somewhere in the void of hidden places.

I hope someone can help,