Can't deploy blueprint project from iOS to Windows

It seems like this never works good.

I get this when trying to launch on iOS:

LogPlayLevel:   [DD] Installing IPA on device 'Protium' ...
LogPlayLevel:   [DD]  ... Install is 5% complete at phase 'CreatingStagingDirectory'
LogPlayLevel:   [DD]  ... Install is 15% complete at phase 'ExtractingPackage'
LogPlayLevel:   [DD]  ... Install is 20% complete at phase 'InspectingPackage'
LogPlayLevel:   [DD]  ... Install is 20% complete at phase 'TakingInstallLock'
LogPlayLevel:   [DD]  ... Install is 30% complete at phase 'PreflightingApplication'
LogPlayLevel:   [DD]  ... Install is 30% complete at phase 'InstallingEmbeddedProfile'
LogPlayLevel:   [DD]  ... Install is 40% complete at phase 'VerifyingApplication'
LogPlayLevel:   Install \ Update of "RollyBall.ipa" failed with Unknown error 0xE8000067 in 10.00 seconds
LogPlayLevel:   [DD]
LogPlayLevel:   Exiting.
LogPlayLevel:   2017-10-31 13:59:02.157 DeploymentServer.exe[176404:9350] RegQueryValueEx failed with error 0x00000002
LogPlayLevel: Took 17.0821833s to run DeploymentServer.exe, ExitCode=1

Any idea what that means? Not a lot of google results and none of them helped.

I fell back to installing the IPA using iTunes 12.6.3 (iTunes 12.7 removed the ability to do this) and all I get from my phone is “Unable to install”. I think this is a separate issue but it’s hard to tell, but it seems to get further than using UE to launch.

What could be causing the second issue? Is it settings? I noticed a while ago that despite having an iPhone 7 running iOS 10 (back then) that I still had to fall back to legacy build settings in order for it to work in the past.

I made a brand new sample project in 4.18. I added my certificates, set the bundle identifier and went “Launch all iOS”. It compiled the shaders and then claimed to have been successful.

There’s no app on my device.

Soooo, 4.18 iOS deployment is just completely, utterly broken?

Hey! I’m having the same issue, I’m running a full blueprint setup. I got my certifications and provision all Valid. I launch to my iphone7plus and i get the same error at the same point. I’m running ue4 4.15. When i package the project it builds but since I have 12.7 I cannot run the package. Where did you find a download for 12.6.3?

If I figure out the error Ill msg back

I found it through googling for “iTunes 12.6.3 download”. That said, that option just isn’t working for me either, so let me know how you get on.

I’m also running on an iPhone 7 plus, if that helps.

Did it work for you before or like me is it the first time trying?

I was wondering if I messed up my Bundle ID, where it says wildcard * I just put the *. wondering if I should of put the com.Yourcompany.Whatever Because it seems to have the error after verifying the app

I updated to 4.18 and my project launches to my iphone7plus now. Good luck!

Definitely worked in 4.16 with no problems, it’s just been a while since I did any mobile dev.

With the wildcard it used to sometimes work better if you used a static identifier rather than the wildcard, including in your project settings by putting in the actual project name instead of [PROJECT_NAME]. I tried doing that too but had no success.

Same problem here. I’m relieved it’s not just me then, I’m new to Unreal since late 4.16 and had luck launching but since 4.17 and 4.18 I get the exact same problem as you @Antidamage . I’m getting to the point where I might reinstall everything or even clean wipe my computer to make sure I’ve not ■■■■■■ it all up trying to fix this.

Two things:

First, I’ve heard that iOS deployment is ■■■■■■ in 4.18 due to a hard-coded path to someone’s documents folder. So that’s breaking it.

Second my ability to package and deploy anywhere for any platform is completely broken in 4.18 as well. It just fails instantly. I have another thread going for that but nobody has commented. I don’t know if that’s causing my problems here or not.

I can package from Unreal but I haven’t tried sideloading the .ipa through iTunes because of the new update and I honestly don’t see why it’d be any different.

I’m half tempted to look at Unity now, I work for a company and we really want to use AR on iOS but with all this hassle it makes me wonder if Unity is worth while. Most likely the same story there though.

I’ve solved this part. I guess this most likely won’t happen to anyone else, but in case it does:

  1. Notice that you can’t open a CMD prompt
  2. Download MalwareBytes and run it. Let it remove a malicious autorun script.
  3. Reboot. Everything is fixed.

So that was pretty bizarre.

Going to check iOS when I finish reinstalling 4.18.

Mobile on Unity is great… if you like 2D. Their mobile 3D stuff is generations behind and performs really badly.

@Antidamage I’ll stick with Unreal then :stuck_out_tongue:

Let us know how it goes with the new install, I might try launching from 14.6.3 given the time so I’ll know at least if it’s 4.18 being the issue for me.

So that issue I mentioned above was the thing stopping me from deploying to mobile. (My initial problem was I had a new device and forgot - once I fixed that by registering it, it still wouldn’t deploy).

The way to test is you have this problem is to hit Windows-R and type “cmd”. If the window flashes up and then disappears, or becomes very small, you have the same problem I did. Powershell did not initially have this problem, but it was unable to run .bat files regardless and would show the same behaviour when I tried.

To fix it download and run MalwareBytes and let it quarantine any auto-run scripts it finds.

That’s good to hear but sadly I don’t think it’s the problem for me, cmd runs just fine but I’ll run MalwareBytes in high hopes.

What’s actually happening when you build? Do you have any logs?

I’ll post one when I next get a chance, but it’s essentially the same as yours, gets to the 40% and errors out, though some times it has failed to find the “project name”, but I am very sure I’ve done the iOS certificate steps correct and have the right fields filled in on the project settings, It did work in 4.16.3 but I have yet to try the 3rd person mobile project to see if it’s some obscure problem with my main project. I’m sure when I have an iPad next to me 24/7 I’ll be able to post about and fix the issue.

Either way my project doesn’t need AR yet so there’s no real need for me to use 4.18 yet, but it would be nice.

@Antidamage turns out my problem must have came from the original project, I’ve no idea what was causing it but I’ve started a new 3rd Person project, set up the iOS certificates for that and once I had no trouble launching to device I migrated over my level and changed the start level around, it launches with no problem now to iOS in 4.18. I have no idea what caused the problem but I’m at least glad to know it’s not the engine, just something weird that I had presumably done along the way.

40% is the system valid the ipa cpu with the device, I guess you build an arm64 ipa, but try to install on an arm32 device(for example ipad mini1), if you install on a device arm64, then should install success.
4.18 default build for ios use arm64, and 4.18 min support ios version is ios 9. to build a arm32 ipa, .you need to change the config file to: