Can't change LOD1 material, grayed out.

Hi Folks,

I imported a staticmesh and created 3 LODs using the auto LOD. Then I tried to change the material of the LODs however it’s all grayed out.
So far I tried by importing my own LODs, by using different meshes, by adding more subIDs, etc. Nothing is working. I even tried in a new project.
I expected to stubble upon a big checkbox somewhere that enables that feature a bit like the “auto compute LOD distance”. However I am still looking for it.

Any idea?


can you show a screenshot of this, please

certainly, here is a screenshot

As I expected, you got confused with the new system. Since 4.14, you have all the materials for your object listed above in the “Materials” tab. There are material slots and slot names. For your object, you only have 1 material in slot 0. If you want to have a different material for LOD1, click on the “+” sign next to the text “material slots”. This will create a second material slot. Set your LOD material there and give it a name. Then, in the LOD1 tab, you can choose the material slot which the LOD is going to use from the drop down. Just select slot [1] there and you setthe material of LOD1 as you wanted.

1 Like

Thanks a lot LeFxGuy. Indeed I did miss this update and I did not found any info in the documentation.
Have a nice day!

Thank you! It’s really helpful.