Download

Can't assign Lightmap Coordinate Index

Now that’s is weird. I moved from 4.23 to 4.24, and now I cannot change the Lightmap UV index. The objects that I added when using 4.23 are working fine, and if a create a new project on 4.24, it works fine, and I can change the index, but in the converted project, If a re-import an FBX, I got stuck at index 1, even though I do have a second UV, or even with auto UVs on.

I’m having the same issue, had a project on 23, migrated to 24 and can’t change Lightmap uv index on meshes I had imported before migration.

I’m on 4.24 and can change “Light Map Coordinate Index” with meshes from earlier version and meshes imported 4.24. Think I did struggle some with a mesh we store custom data in UVs but this was me not having the correct settings in the “Build Settings”, changed the “Destination Lightmap Index” then reimported and it too worked as expected.

Nope, still does not work. While yes, it auto-generate the lightmap UV, the engine still does not let me assign the UV on index 1 as the lightmap UV. Everytime I try to assign it, it goes back to 0, even though I have 2 UVs

**RockNBurn **have you found any solution? I have this problem too, after migrating from 4.23 to 4.24 i can’t change lightmap coordinate index. When i trying to change it’s going back to 0 or engine just crashing.

So, i found temporary solution for me and maybe it’s will be helpful for others. What you need to do it’s just export your meshes with “Level Of Detail” option enabled, change location of source file in asset properties, set “import mesh LODs” option and hit Reimport base mesh + LODs. Only then you will be able to set LM index.

It’s an engine bug, sources of 4.24 have been fixed, you can download and compile, but you have to wait for 4.24.2 or 4.25 if you want to use binaries.

Thanks, I’ll try that with one asset first.

No dice. Still does not work.

Actually, the workaround can be a bit simpler: Just set LOD Group to ‘none’, Number of LODs to 1, apply changes. Then you’ll be able to assign your Light Map. But of course you won’t have LODs.

This is such a critical bug which needs immediate hot fix released in form of 4.24.2 … we cant wait for 4.25…

Just got a mail on my bug report from the developer team: due to the bug requiring API changes, it will only be fixed in 4.25 (API changes are not allowed in hot-fixes). However, as mentioned above, if it’s highly critical in your case, you could consider compiling a version of the engine from source, to integrate the fix. (Fix CL is listed on bug tracker).

Hey, that actually works, Thanks, I’ll try to bake it again.
considering I’m not working on a game, but a portfolio piece, I don’t mind losing LODs

BTW, you don’t actually need to set the LOD group to None, just set the number back to 1.

A quick fix is to set the Number os LODs to 1. You cannot use LODs, but you can bake lightmaps again.

I don’t understand because this has been fixed in UE4.24 sources, you can read this:
https://forums.unrealengine.com/unreal-engine/feedback-for-epic/1705997-4-24-light-map-coordinate-will-not-change-off-of-0
I have tested myself so I think, that if there will be a 4.24.2, the fix will be integrated.

Hello is this fixed yet or do I have to use github. I have never used github before. Or do I just resinstall the UE4?

In 4.25 preview I still have these issue. Can’t change it to 1. So apparently we can wait till 4.26 lol

I too have encountered this issue. Many times in fact. I did manage to work around it , but I’ve had several times where setting the Light Map Index manually would crash my engine. But anyways, these are the steps i took:

  • Delete all UV’s
  • AutoGenerate them using UE

While this is far from perfect, in my projects this has let me define a custom lightmap index. Also be sure to set your Destination Light Map Index as well.

I am on 4.25.4 and I had the problems mentioned here with some 3D assets imported from Megascans.
I changed under LOD Settings/LOD Group from “None” to “Vista” or “SmallProp” and than I could change the LMC Index to 1. It backed without Error!

One way to solve it is to enable “Generate Lightmap UVs” in Build settings, and click Apply. Then set the Destination LM Index to 1, and the LM Coord Index to 1, Source to 0.