Cannot save map - graph linked to private object

Hi everyone,

I am working on a template for the Marketplace and yesterday started cleaning out my folder structure. When I tried to move my main demo map (LevelCorneria) I encountered the errors below. It seems that there are 4 textures referenced somewhere that are missing - however when I go thru all my materials, no broken references are found.

I tried to clone the level and rename it, and that seems to work somewhat, but if I try to move the new (clone) map, the same error occurs. I rebuilt lighting to try to get rid of the errors, but they still come up.

I have seen other users asking a similar question on the AnswerHub but they are always using a code project - this is a full Blueprint project so no custom class has been created.

Can someone please guide me in troubleshooting this? How can I find out which textures are missing, or how can I clear these references to “external objects”?

Any guidance would be greatly appreciated!

Thank you!




Hello CoquiGames!

I wanted to ask if you found a solution to this problem as we are encountering that issue and we’ve spent too much time already trying to sort our folders into something more structured.

Thank you buddy!

Hi Dan,

Its been a while but I believe I was able to clone the level, move it to my new location and very painfully save when I got the error message.

Also try making your level have dynamic lighting and deleting the build data. I remember messing with this as well.

Sorry I cant give you a straight answer but this was a while back. I never found a .“Proper” solution though :confused: