Cannot find sessions when hosting in standalone game

So, I’m trying to host and join LAN session. And it works nice, but only when I’m hosting the game in editor and trying to connect to it from standalone game. Suprisingly, when I’m hosting in standalone game, FOnlineSessionSearch::SearchResults is empty both when I’m trying to connect from editor or standalone game.

you got online subsystem on? if not only lan will work

The problem is even LAN doesn’t work in standalone game (Sorry for vague description in original question, I’ll fix it right now).

I added OnlineSubsystem into Build.cs

PublicDependencyModuleNames.AddRange(new string[] { "Core", "CoreUObject", "Engine", "InputCore", "HeadMountedDisplay", "AIModule", "UMG", "GameplayTasks", "OnlineSubsystem", "OnlineSubsystemSteam" });

And appropriate line to DefaultEngine.ini:


Again, it works perfectly fine when I’m hosting in editor, I get some problems in standalone / packaged game.

Thank you for the reply!

Solved this by passing different session name to CreateSession function (i used NAME_GameSession before). Still no idea, why it helped.