Download

Camera surrounded by following circular shadow Bug? 4.22.1

What causes a circular shadow to appear around the camera/player & how do you fix it?
The engine crashed on me and upon loading the same level, there is now a permanent shadow about 10-20 feet away entirely circled around the camera or player character. If you move the camera, the shadow moves along with it. It looks as if the player had been carrying a lantern and only a circular portion of light is being shown around the character the rest being circled by a black shadow.(I never implemented anything like this so I have no idea what caused it) Objects that arent terrain or floors sometimes can still be seen even within the shadow. This shadow bug seems to happen on most levels. I tried rebuilding lighting & it doesn’t fix it.

I think it’s just the default pawn’s sphere which is casting a shadow. Try pressing Eject and moving the camera back while you’re in Play In Editor mode, you should see a sphere floating there.

Moving all of the content to a new project “fixed” the problem, but its really not a good solution, there must be a better way.

I don’t believe this is the case because it happens when flying around in the editor without a pawn as well. Only a circle of light surrounds the camera the rest of the world in darkness.

I’m having this problem still off and on, sometimes if I restart the editor it goes away but I can’t figure it out… Its happening on every map, adding new lights the area still stays pitch black like it hasnt loaded or something.

It might be easier to find help if you’d post a video or at least a screenshot of the problem. :slight_smile:

I will do that the next time it occurs. I deleted the engine swarm folder and it seems that has fixed it again, for now. I’m assuming files in there aren’t loading or are getting corrupt somehow.

its really not a good solution, there must be a better way.

Im not sure, if i undestood. You mean, when you are in editor or PIE, then around you (few meters or feets) is casted something like circular shadow right ? I have this problem and i fixed it with disabling Cast Shadows in DirectionalLight.
Cheers ! :slight_smile:

That works ya, but what causes it in the first place ? Shadows are part of dynamic light which defeats the puprose…nice that it works oddly, what causes the sphere around character, I get it too. BTW, where is swarm folder to delete ? I’ve not used much as I run out of ram not long after starting light build.

Honestly, i have no idea. It has zero logic, because only 3d object or things can cast shadows. But lighting cant do it itself. Its probably bug. And about swarm, if you want to use only dynamic lighting, then set all lighting to moveable, and go to world settings and under Lightmass find and enable Force No Precompute Lighting. It will stop building lightmaps so i think it can be good solution. :slight_smile:

Ya my computer doesn’t have the power to build that atm (ram, takes too long) ,but that’s changing soon :wink: Miss shadows as scene looks LESS w/o them ofc, also turning shadows back on does nothing now,shouldnt’ there be shadows in dynamic even without building light,I know there used to,is this another bug in 4.24.2 possibly ? Turning shadows on, creates that weird circular shadow around chacter,but shadows don’t appear everywhere they should especially at base of tall towers etc.

Lighting, the bane of almost all our existence, here anyway :wink:

When you say “a shadow” we assume a dark circle around you, lighter colors further out.

If you mean the opposite, highlighted area around the player, dark further away, then that’s probably an issue of a Post Processing nature.

If that’s not the case and you have an actual shadow,
Create a new player character or load in a default blueprint. chances are you changed something in it or added a component that is casting a shadow.

HI , yes exactly dark circle around me and lighter ahead, I don’t recall it ever occurring in prior engine version(s).Should have been
more forthcoming, using Sun&Sky with Sky Atmosphere , no Post Process anywhere just those two are fantastic.

This is caused by the Exponential height fog (If it is the same issue i have!)
I set the max cover distance of the fog to the lowest. And it makes a foggy ring around the camera on larger levels/landcapes.

If not this. Then try to enable distance fields. Then in your sunlight, enable FAR SHADOWS in the bottom of the list. ( set cascades to 1)
Then you could also increase the ray tracing distance for the shadows. (far shadows only work with distance fields on!)
AND YOU NEED SKYLIGHT SHADOWS ON!

Well tried those but nothing helped, THEN I removed atmosphere/fog sun light under directional light which is under Sun & sky, the new feature in 4.24,and now the circle of dread/shadow, is LIGHTER, but stil visible barely, prob. not enough to notice really.

Is that a bug ? If not, what’s still causing it .
To verify, sun & sky has its own fog, BUT without the fog, that gets rid of ‘most’ of the ring of death ;0-,the SKY turns all black,so then how do I get sky back…I’ve seen some youtube videos, but since can’t find them anymore.

Do you mean start distance re: cover distance ? Not seeing anything else on Exp height fog.

I’m having also, a horrific trouble getting lighting to look anything but plastic, here and there moments of wonder…wait for 4.25 and hope ?;))

I think you may need to tweak your shadow settings on your directional light. Select your directional light, and in the Details Panel adjust the “Shadow Amount” values. Hope that helps.

Ty somehow all this time I’d missed that , sigh, but while it does help, it doesn’t remove it entirely. , but its ‘better’ so I can live with it easier. Is this just the nature of the beast or is it likely .25 will fix this for good,crossing fingers ;)) Of course I could just go static but my hardware isn’t up for the task, running out of memory with 8gb so I’d have to wait. But with my world comp world, my understanding is dynamic is the way to go as lightmaps get crazy as your world size increases.

I’ve just updated from 4.23 to 4.25 and I’m experiencing this issue.

Decreasing shadow amounts or giving up on dynamic lighting are not really feasible workarounds.