Cable Component not working properly in 5.0

Hey guys, auper excited about the release of 5.0!

Got a small issue with cable components that I’ve been scratching my head about.

After updating to 5.0 all cable components started acting unpredictably. After I attach them to a physics object and then push that object around, the cable becomes transparent/barely visible as long as the object is moving. Moving the object in the editor outside of runtime works fine, it’s seemingly only when physics is being applied to the object that the cable is attached to that this occurs.

It works fine in 5.0EA version, but something seem to have broken in 5.0. Ive tried in a few different projects, some old upgraded ones, some completely new ones, and the issue seems to be present in all of them.

Has anyone else had any similar experiences with this? And if so, is there any solution to this?

Thanks in advance!

1 Like

Here is a GIF of the behavior, can’t seem to get it to work in any project that uses the 5.0 release version:

5.0 EA works fine tho, very strange!

Just migrated to UE5, My blueprints that were building cables now fail, the add cable component node changes to a regular add component and fails the compile cant find the normal cable variables end point etc. Not only that all the blueprint actors present in the persistent level got their positions wiped out and they are all stacked up at 0,0,0. The plugin is loaded and I can rebuild the nodes but they didn’t stick. Next time I opened the level again they would fail. The fix was changing the loading phase to PreDefault in the CableComponent.uplugin after that the cables worked again. This file is located here: “C:\Program Files\Epic Games\UE_5.0\Engine\Plugins\Runtime\CableComponent\CableComponent.uplugin”

We’re experiencing the same(or very similar) rendering issue. Cable renders in front of some actors but behind others. This wasn’t an issue in EA. only started after updating.
We are currently on UE5Preview2. Im curious if this is fixed in UE5.0.1

Report it as a bug.

I was unable to reproduce this though so you should probably include your project.

I get the same issue. Cables renders infront or behind the world when they are attached to a object (Maybe just like physics Objects). Simulating in the blueprint editor looks fine but playing the game makes it happen. I’m in an old test project right now that I’ve updated from first the First UE5 preview. Has anyone tested if it happens in a new project created in the current UE5? I’ve heard people having some wierd issues when updating old early UE5 projects to current so… =/ I’ll give it a try later.

I have the same exact issue. Transparent cables =) Have you found any solution?

I am having the same exact issue, I can’t find any way to fix it

Hello,

This was already reported as an Engine Bug UE-149249
Issue is related to Unreal 5.0. It does not occur on previous versions.
Unfortunetly we have to wait for ver 5.1

Meanwhile there is a partial fix for that.
You can attach the End of cable to not moving object if it possible in ur projects (it should be in the prototype posted above)
When the End of cabel isn’t moving, the issue will not occur.

EDIT: Also please upvote this ticket UE-149249

Cheers

2 Likes

I just voted, thanks :slight_smile:

Only my start of the cable really moves, the end location for my grapple hook only moves when it needs to attach to a new grapple spot and then stops moving but stays invisible. Not just in the sky it has issues on everything but weirdly enough the grey grid prototype material makes it more visible? Weird stuff.

I had same issue, using attach end to component name and socket name in cable tab instead using parent socket fixed mine, dont know if that apply to yours.

Guys, I have just discovered that cable renders properly when non-ninite mesh is on the background and it turns invisible in front of nanite meshes and in front of the sky.

1 Like

‘Attach end to component’ didn’t help in my case, ‘attach to socket name’ - too. Neither either of them, neither both.

Guys, some good news, today I noticed that the issue was fixed 13 days ago: https://github.com/EpicGames/UnrealEngine/commit/65733c97e85aaf5bb3f3816063cae83d24a6843b

So, we’ll have to wait until the next UE5 update unless you’re using the source version.

Ah fingers crossed it’ll fix any cable issues, thanks for letting us know

1 Like

Temp Fix found,

  1. Give the cable component a material
  2. Make the material translucent, Default lit, Surface
  3. Give the material a base color or texture
  4. Set the opacity to 1 of the material
  5. Fixed

#A_ColtZz Fix

9 Likes

It works, thank you. Hopefully, Epic will include the their commit to the next 5.0.3 update.

Unfortunately, I don’t see there the UE-149249 fix for the cable component. Not sure why. Any ideas?

1 Like

I belive hotfix-patches are only pushing fixes to bugs with high severity like crashes, stability issues or issues afecting main functionality of engine.
Probably every fixed bug needs to be retested by their internal QA before merging code into main branch. This one is more of a minor visual issue so they don’t even bother about it for now.

1 Like

I see. I’ll wait a little more and probably end up switching to the source version of the engine in order to paste the fix into the cable component class.

1 Like